Mazda 6 Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
have a 2004 mazda 6i, and after replacing a battery, because it wouldnt start, anything that is supposed to work with out a key in the ignition is not. i am almost positive my starter must be replaced, but my problem goes deeper. for example my interior lighting, display panel lighting, power door locks, trunk pop, or radio are not working. i have checked all of the interior fuses, p. door fuse and none of them are blown, anyone have a clue as to what it could be? any suggestions would be helpful, thanks in advance. . .also if anyone knows what the (BOSE RELAY) function is it would be helpful because i do not have a Bose stereo system, and if anyone knows what fuse runs the key-less entry system that would be perfect! ! ! i figured i would ask here instead of posting separately :)
 

·
Registered
Joined
·
25 Posts
Discussion Starter #2
fixed it, found out the main 100a fuse is blown, now i just need to figure out how to remove it and replace it, i think the fuse is in the blue housing and i cracked that, lets see how it goes!
 

·
Registered
Joined
·
49 Posts
i has about to suggest a fuse in the cabin, i accidentally shorted a fuse when i crossed wires today. my power locks, interior lights and and radio stopped working, plus when i started the car, my gauge cluster was going crazy.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #4
i has about to suggest a fuse in the cabin, i accidentally shorted a fuse when i crossed wires today. my power locks, interior lights and and radio stopped working, plus when i started the car, my gauge cluster was going crazy.
thanks, i found out it was the main 100A fuse, fixed the interior problems now working on the starting issues!
 

·
Registered
Joined
·
39 Posts
i has about to suggest a fuse in the cabin, i accidentally shorted a fuse when i crossed wires today. my power locks, interior lights and and radio stopped working, plus when i started the car, my gauge cluster was going crazy.
Hi,I am having the same issue with my mazda do you know wich fuse is it ?
 

·
Registered
Joined
·
39 Posts
How to check the 100A fuse? Pls help
it's the one with the red circle (under the hood right beside the baterie ) take a look a the metal piece look like a ''H'' if its broken the fuse is dead. if you have the same probleme as me check the fusebox in the car look for the mirror fuse and the accesories fuse.

 

·
Registered
Joined
·
1 Posts
I'm having the same problem, cd player will not work along with dash display, interior lights. Also door locks only work when car is turned on and trip odometer resets when car is turned off and back on. Changed the 100amp fuse in under the hood still didn't fix the problem. Any other sugestions? Thanks ahead of time!
 

·
Registered
Joined
·
5 Posts
I was installing my new led light kit (corksport) in the vanity mirror while my doors were open and it sparked.. once the spark came I got all the issues meantioned in this thread!
I replaced the main fuse (120amp) and still have the issue, so its surely not that fuse (which was a pos to get out!!). I will check the mirror fuse and acc fuse inside the car and hopefully thats the issue. I will edit when I fix the problem.
 

·
Registered
Joined
·
1 Posts
Hey Guys, I just bought a 2004 6i the other day and noticed that the radio display was not up to par and I could not read anything on the display. After tapping the display some of it showed but not the rest. I need suggestions on how I can fix this. Also I was wondering if anyone knew where I can find map box pieces. Mines not level with the rest of the dash and is missing what looks like a small pin inside one of the hinges. Thanks Guys.
 

·
Registered
Joined
·
203 Posts
Hey Guys, I just bought a 2004 6i the other day and noticed that the radio display was not up to par and I could not read anything on the display. After tapping the display some of it showed but not the rest. I need suggestions on how I can fix this. Also I was wondering if anyone knew where I can find map box pieces. Mines not level with the rest of the dash and is missing what looks like a small pin inside one of the hinges. Thanks Guys.
This needs to be posted as a new topic.
 

·
Registered
Joined
·
1 Posts
Opilee Did you find the Solution?

Hello Opilee,
I have the same exact issue. Were you able to find the solution?
Thanks!

i has about to suggest a fuse in the cabin, i accidentally shorted a fuse when i crossed wires today. my power locks, interior lights and and radio stopped working, plus when i started the car, my gauge cluster was going crazy.
 

·
Registered
Joined
·
9 Posts
I was installing my new led light kit (corksport) in the vanity mirror while my doors were open and it sparked.. once the spark came I got all the issues meantioned in this thread!
I replaced the main fuse (120amp) and still have the issue, so its surely not that fuse (which was a pos to get out!!). I will check the mirror fuse and acc fuse inside the car and hopefully thats the issue. I will edit when I fix the problem.
Were you able to solve the problem yet, i'm taking mine to the dealership monday after 3 months lol... If you were able to find a fix pls let me know...
Thanks in advance!
 

·
Registered
Joined
·
9 Posts
So after a Couple of months of waiting for this problem to be fixed I decided to drop off the 6 at the dealership, I had worried that it was going to cost an insane amount to have it fixed... 2 HRs later the mazda dealership called, figured they were going to share some bad news, my thought's were exactly wrong, easy fix and only $60 total to have it checked out and new fuse put in! The problem solver was the "ROOM FUSE" so for everyone with this problem check that and change it even if it looks to be good, they said this was not a common problem but everyone overlooks it! HOPE THIS HELPS and you don;t go through the pain that I have!!!
 

·
Registered
Joined
·
3 Posts
what sup guys, i have a 06 6i with boss radio, it shows the time but it doesn't show what station I'm on or the temperature but everything else works.the dealer said i have to replace the radio display for $250, i check the fuse box everything seems to be good, is their anything i should look for. thanks in advance.
 

·
Registered
Joined
·
2 Posts
my interior lighting, display, power doorlocks, navigation or Bose radio doesn't work

Hi guys, sorry for my bad english...
I have a Mazda 6 2.3L (2003) with Bose and Navigation.
my interior lighting, display panel lighting, power door locks, navigation or Bose radio are not working.
Everytime when i turn on the ignition or started the car, my gauge cluster is going crazy too, also odometer get reset.:crying:
My check cople of fuses also the main fuse 100Amp are not blown.
clubdriv21, ahk6 ...have fixed the problem with replace the "ROOM FUSE " but, where can i find the "ROOM FUSE"????
Mu fusebox is about the same as on the picture that "alextrem6" put it on this topic.
Is there any other fuseboxes then the fusebox on the hood near the battery?
 

·
Registered
Joined
·
2 Posts
Ok, i just got fixed! I found the "ROOM FUSE" it's in the little fuseboxes near where jou put your left foot place! (EUROpe model)
 
1 - 20 of 23 Posts
Top