Mazda 6 Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
803 Posts
Discussion Starter #1
i recieved my xcel intake today, a day earlier than i was epecting. im psyched! can't wait to install it, hopefully ill have time later tonight.


anyone have any tips to relay to me to make it easier? it looks more involved than the install on my previous car (02 firebird), but i can't wait to get on it
 

·
Registered
Joined
·
706 Posts
Pics? Look forward to seeing your et improvement.....
 

·
Registered
Joined
·
1,307 Posts
I got the Mazdaspeed CAI, and it took me about an hour to put it in (i had taken the resonator out prior to)

umm, just make sure you unplug the battery terimanal, just in case.

otherwise, installing the damn thing is really easy, just follow the directions, and you'll be set. if you get stuck, search on the fourms, and trust me there are PLENTY of topics on how to put it on, troubleshooting...ect

If you get the check engine light after installation, just disconnect the batter terimanals and connect them again, it'll all be gone!

i like your E.T., btw
 

·
Registered
Joined
·
967 Posts
i recieved my xcel intake today, a day earlier than i was epecting. im psyched! can't wait to install it, hopefully ill have time later tonight.
anyone have any tips to relay to me to make it easier? it looks more involved than the install on my previous car (02 firebird), but i can't wait to get on it
[/b]

CP-E Intake installation thread. ;)
 

·
Registered
Joined
·
2,044 Posts
turn your wheel all the way to the left. don't worry about removing bumper or lifting vehicle. install should take <30 min, <60 if you really take your time.
 

·
Registered
Joined
·
803 Posts
Discussion Starter #6
turn your wheel all the way to the left. don't worry about removing bumper or lifting vehicle. install should take <30 min, <60 if you really take your time.
[/b]

sweet, thats what im talkign about. neat trick, ill give that a shot.

koko- thanks bro



as far as et goes- ill probably be going to the track on the 2nd now that i got this :) last time i ran in 75 degree weather. im looking forward to 40-60 degree weather this time around, and if i can lower my 60' to a 1.8, then ill hopefully crack a [email protected]

im crossing my fingers that my dsm bov gets here before then also.

gunning to be one of the quicker stock/just intake MS6's around ;)
 

·
Registered
Joined
·
14 Posts
When did you order yours? I've been waiting on my CPE intake for almost three months now. According to Cullen, I should have it by this weekend though. I hope it's worth the wait...
 

·
Registered
Joined
·
2,044 Posts
there are many online retailers for CPE now. it all depends on who you bought it from. 3 months wait seems excessive for the xCel.
 

·
Registered
Joined
·
1,498 Posts
im crossing my fingers that my dsm bov gets here before then also.

gunning to be one of the quicker stock/just intake MS6's around ;) [/b]
My 1g dsm bov should be arriving soon as well (won it on ebay a month ago, lol)...then you and i can duke it out for tops of the minor-modders :drive:
 

·
Registered
Joined
·
803 Posts
Discussion Starter #10
My 1g dsm bov should be arriving soon as well (won it on ebay a month ago, lol)...then you and i can duke it out for tops of the minor-modders :drive:
[/b]


im really looking forward to it bro! looks like we'll have damn near the same exact mods, including the shark fin :D

i hope the bov gets here by the weekend...fgraziano where you at?! lol


i ordered my intake last friday, and it got here today (tuesday) along with my audiolink for my ipod.

waiting on my shark fin which should show up in december, and my hid matched fogs...those should be here soon.
 

·
Registered
Joined
·
1,498 Posts
haha, almost the same mods indeed...

dark side: cp-e intake and audiolink
light side: mazdaspeed intake and auxmod

you're going down! lol
 

·
Registered
Joined
·
803 Posts
Discussion Starter #12
ok, just got done, took a lot linger than i thought it would even with 3 people working on it.

anyway, because i disconnected the battery, my smart key doesnt work anymore and none of my windows except the driver's side will go down at all.

anyone have pointers on how to rectify this without going to the dealership??


btw- first impression...holy shit i love the sound!!!!1
car doesn't feel any faster imo, but i think the ecu may need a week or so to adjust and re-learn due to the amount of new airflow. or maybe my butt-dyno is off. ill find out when i get to the track.


my car sounds AMAZING!!!! money well spent, and im sure ill appreciate it even more once i have the smart key/windows working, and the car starts to love the extra air :)
 

·
Registered
Joined
·
1,334 Posts
Not sure about the Smark Key, but for the windows, before somebody jumps in to tell you to use "Search", reset each window by rolling the window up to it's closed position and holding the switch up until you hear a soft click. This resets the upper position of the window so the motor now knows where it is. Do this at each door. After this everything will work again. It's also covered in the owner's manual and in this forum ad nauseum.
 

·
Registered
Joined
·
803 Posts
Discussion Starter #14
Not sure about the Smark Key, but for the windows, before somebody jumps in to tell you to use "Search", reset each window by rolling the window up to it's closed position and holding the switch up until you hear a soft click. This resets the upper position of the window so the motor now knows where it is. Do this at each door. After this everything will work again. It's also covered in the owner's manual and in this forum ad nauseum.
[/b]

oops. well, i give the owner's m,anual a once over, just figured i'd ask in case there was something real easy i could do to reset everything

does your method for the windows still work if they are all already in the up position?
 

·
Registered
Joined
·
1,498 Posts
no, you have to put them down a tad first, then go up and hold it for a couple seconds. just make sure you do it at each individual door's switch, not from the master panel
 

·
Registered
Joined
·
803 Posts
Discussion Starter #16
no, you have to put them down a tad first, then go up and hold it for a couple seconds. just make sure you do it at each individual door's switch, not from the master panel
[/b]

a-ha. they werent working from the master panel at all.

ill try once im out of class. thank you skoda and digger


ok gys, apparently resetting the windows also brught the smart key back. im ready to roll....first test comes against a swapped I/H/E/50shot crx tonight....on a closed course :devil:
 
1 - 16 of 16 Posts
Top