Mazda 6 Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
I have a 2005 Mazda6 3.0 V6 with the Bose sound system, I got this new headunit from Amazon :

So, I have everything hooked up as far as "Plug n Play" goes. There is a connector or two that just seem to have no place on this unit. It did come with another connector which features several RCA style connectors but idk how I'd use it. Also, on the Amazon listing, it says it includes this "Canbus" which mine did not come with, dunno if that's relevant.

I have NO audio, my steering wheel controls aren't working, the Hazard light has to be held in to stay on- not toggled, and the AC lights on the unit don't turn on when I push them. Otherwise, all of the features on the headunit itself work fine, it powers up and I can go through all the menus and etc.

Now, I knew my car had a Bose system, I did not however realize that meant it had an amp under the passenger seat until I researched online. I haven't connected anything to the amp nor removed anything from it, I don't even actually know how to access all of that. I'm not a complete noob in car audio but for the sake of this install, let's pretend that I am. If anyone can help me get this working I would be greatly appreciative. The radio looks super sleek in my car and effectively has a lot of cool features I'd love to be able to have in my car. Trying to avoid sending it back and using the factory stereo :(

If you guys need any pictures or anything to help you assist me please let me know.
Vehicle Car Automotive design Motor vehicle Gauge
Circuit component Computer hardware Electrical wiring Electronic engineering Electronic instrument
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #2 ·
I also found this diagram, this is not the same brand/model of stereo I purchased, but it looks nearly identical.
Font Parallel Musical instrument accessory Rectangle Event
 
1 - 3 of 3 Posts
Top