Mazda 6 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I am having this problem with my car it is idleing wierd it keeps revin up and down but never goes over 1000 then eventually the car will die. I noticed that the tcs light stays on and another light does its theyellow light next to the door ajar light then the car sounds like its sucking air after every rev..and Im not even touching the gas.

If anyone knows or has any idea what this might be Id appreciate your help
Thanks.
 

·
Registered
Joined
·
51 Posts
I am definitely no expert, but I had something like this happen on my Eclipse. It turned out to be a vacuum leak. It wasn't too hard to find, because I could actually hear the leak when I began searching.

It's something to begin with, at least.
 

·
Registered
Joined
·
981 Posts
If Crossbow's links aren't the problem, I would double check to see if you have any vacuum leaks up front.

Have you installed the CPE or anything like that recently? For me, when I had something similar to your situation, the hose running from the intake to the PCV on the engine was broken causing a vacuum leak. Double check all hoses for any splits or cracks.
 

·
Registered
Joined
·
4,775 Posts
The final problem could be a MAF sensor. If the MAF sensor is bad, you will get a lot of those problems in addition to the car running really rich
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
5 Participants
dabears2k
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top