Mazda 6 Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello everyone; signed up some time ago, but haven't had a chance to post.


A few weeks ago, about a mile from my home, my 2004 (3.0 Sport) started shifting very roughly--in all gears, upshifting and downshifting. I drove it about a mile, then nursed it home. I haven't driven it since.


About a month earlier, it had one rough shift--so rough I thought someone had rear-ended me--but no transaxle problems since, until the above happened.


While the car was under warranty (it now has 192,xxx miles on it), I brought it in for a rough shift, and was told that a $300 hose had failed. Is this something similar, or do I need a new transaxle--or a new car?


Any and all help is appreciated. Thank you.
 

·
Rally Racer
Joined
·
2,268 Posts
Hello everyone; signed up some time ago, but haven't had a chance to post.


A few weeks ago, about a mile from my home, my 2004 (3.0 Sport) started shifting very roughly--in all gears, upshifting and downshifting. I drove it about a mile, then nursed it home. I haven't driven it since.


About a month earlier, it had one rough shift--so rough I thought someone had rear-ended me--but no transaxle problems since, until the above happened.


While the car was under warranty (it now has 192,xxx miles on it), I brought it in for a rough shift, and was told that a $300 hose had failed. Is this something similar, or do I need a new transaxle--or a new car?


Any and all help is appreciated. Thank you.
This is a relevant problems for me since I drive basically the same car.
Can I ask how often you replace your trans fluid?
 

·
Registered
Joined
·
508 Posts
I'd start by digging up the paperwork and find out which hose was replaced, then inspect it.
My previous 6 did that during Winter when it was very cold, normalized within 5-10 minutes.
 
1 - 4 of 4 Posts
Top