Mazda 6 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
This morning my speed6 had a CEL. Car was working fine though and I took it to the dealer to connect it to the computer to see what it was.. The guy who connected it said the main mazda guy was on vacation and he didn't know how to read the computer but he did reset the thing so the CEL went away and told me to come back if it came back on...

So I drove away and immediatly noticed that the car felt like 100 bhp was missing, no lowend pull, it was like the turbo wasn't spooling up?!?

Few minutes later it felt like the car was giving power at high rpm's, over 4k but still a LOT of lowend pull missing... Dealer said to come back with it and its going in a few hours.. But is this normal ?? After a computer reset the car may take awhile to give full power?
 

·
Registered
Joined
·
1,390 Posts
It sounds to me like the guy who worked on your computer screwed it up and shouldnt be working on Mazdas if he doesnt know what he was doing. I'd say raise some hell and get your car back to normal and find out what the original cell was. Also find out what that idiot did and why the car reacted that way. Good luck.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #3
thanks... but it strange that it seems to be getting better...

anyone else had a reset on the computer? did you experience anything like this?
 

·
Registered
Joined
·
979 Posts
Turn around and go right back to your dealer and demand a guy who knows what he is doing.... You do not know what this guy may have done to the car not to mention any long term effects... You may just want to go to another dealer instead have them look at it.
 

·
Registered
Joined
·
1,396 Posts
Any time the computer is reset it erases the long and short term fuel trims. You car is always going to run a little differently while it relearns the trims.
 

·
Registered
Joined
·
820 Posts
Generally it's a good idea to let the car idle for a few minutes WITHOUT touching the gas after the trims have been reset. Watch as the idle "hunts" for a while, it will then seem to dial itself in. Usually after just a minute or two. Then shut the car down, restart and the idle should be nice and smooth. This should be common practice.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #7
well I took the car back to them and they said, and sorry for my translation, dont know car technical english ;)

"the valve's/blades in the sucktion duct (air?) arn't opening completly" and the ordered some spare parts (some sensor and stuff) which they'll have in a week or two... (Im not very technical with cars, know about as little about cars as I know much about computers :sarc:

Gave me the car back though and its much better now, high-end power is practically back to normal but I still feel some low-end torque is missing
 

·
Registered
Joined
·
595 Posts
well I took the car back to them and they said, and sorry for my translation, dont know car technical english ;)

"the valve's/blades in the sucktion duct (air?) arn't opening completly" and the ordered some spare parts (some sensor and stuff) which they'll have in a week or two... (Im not very technical with cars, know about as little about cars as I know much about computers :sarc:

Gave me the car back though and its much better now, high-end power is practically back to normal but I still feel some low-end torque is missing
[/b]
dude, what the heck are you talking about? Did they not give you a work order - this would have the parts they replaced and what service was done to the car.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #9
dude, what the heck are you talking about? Did they not give you a work order - this would have the parts they replaced and what service was done to the car.
[/b]
why would a have a work order for something that hasn't been done? :sarc:

Like I said, they ordered the parts and they will have them in a week or two, and I said sorry for the translation, here is the Icelandic version for you "Blöðkurnar í soggreininni opnast ekki alveg og við pöntuðum nýja varahluti í það, skynjara og fleira, kemur eftir 1-2 vikur"
 

·
Registered
Joined
·
33 Posts
why would a have a work order for something that hasn't been done? :sarc:

Like I said, they ordered the parts and they will have them in a week or two, and I said sorry for the translation, here is the Icelandic version for you "Blöðkurnar í soggreininni opnast ekki alveg og við pöntuðum nýja varahluti í það, skynjara og fleira, kemur eftir 1-2 vikur"
[/b]
LOL
 
1 - 12 of 12 Posts
About this Discussion
11 Replies
9 Participants
crossbow
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top