Mazda 6 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
144 Posts
Discussion Starter #1
I picked up some new front pads from RPM Hawk HPS for my 04 6S 5 door.

I noticed when I put the new pads on though that the sides without the wear indicator don't have the little holes to reuse the factory springs that appear to seperate the pads. On of my front pads is trashed though so I go ahead with the new ones anyway. I noticed during the emergency braking during break in that the pads gripped even after I removed my foot from the brake. So much that I'd spin the tires when I hit the gas kinda like power braking.

Did I get the wrong pads? The gripping possibly just temporary? Any idea how to tell if one of them is dragging? I don't notice any pull left or right either during braking or not other then the normal pull down the pitch of the road.
 

·
Registered
Joined
·
1,573 Posts
Without the pins pushing the pads apart, when you clamp the piston it the pads must stay clamped. The pads aren't seperating from the rotor so it's like your braking all the time...I'm sure this will hurt fuel economy, keep track of it. I have the hps pads and mine had holes on both sides. Either had some dirt in it and you just gotta poke through or some manufacturer defects. Keep an eye on this.
 

·
Registered
Joined
·
144 Posts
Discussion Starter #3
I pulled them back off again and the first set I did had the holes so 3 of 4 had them. The 4th pad wasn't drilled for it at all. It does feel lighter now with the one set fixed, just gotta contact rpm now to get a replacement pad for the 4th.

No noise at all though with them so I'm pretty happy otherwise
 
1 - 3 of 3 Posts
Top