Mazda 6 Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
Okay,

I have an 04 6s Hatch, It is velocity red, and I love it, However... like most of you in here, the stock stereo, (mine is Bose) just isnt enough. So in about 2 weeks, I am going to install my Stereo into my 6, and I cannot for the life of me decide what to do of where to start for the design of the sub box, and amp racks.

I am using two kenwood excelon oversized 12's, a US Amps 1500 Watt 4 channel, and a kenwood Excelon 1600 Watt Mono channel, and I want some sort of an amp rack and I need a spot to put my Cap also.

Does anyone out there have pics of a cool design that would look good with the Huge opening of the Hatch?

Thanks a lot,
 

·
Registered
Joined
·
70 Posts
Discussion Starter #3
Thats awesome!, ...

Thanks a lot
 

·
Registered
Joined
·
536 Posts
Thats one of the my favorite on this site. Nice looking and still a very funtional trunk!
 

·
Registered
Joined
·
246 Posts
What is an oversized 12??

if it is oversized....its no longer a 12.

and I would place the cap in the garbage, useless piece of crap is what a cap is.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #6
An oversized 12 is what kenwood calls it. it is almost 13", ...


and easy on the cap thing, when you run a big system, it makes a difference.
 

·
Registered
Joined
·
491 Posts
not really IMO. caps aren't great for much although some say it is good for SQ as it keeps the voltage rails stable but even then you need a lot of farads. Not gonna get too much into a debate tho as many have different issues with what works. So much voodoo involved in these things.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #8
Far enough!

What type of system are you running in your 6?

I am in the process of upgrading mine and am open to suggestions
 

·
Registered
Joined
·
70 Posts
Discussion Starter #10
okay.. so you know more then me... I was never disputing that... all i was saying that on my last car.. my lights would dimm...and w the cap.. they did not.... that is why I am putting it in my new system...


far?
 

·
Registered
Joined
·
491 Posts
Far enough!

What type of system are you running in your 6?

I am in the process of upgrading mine and am open to suggestions
[/b]
Well, I currently have an Eclipse CD8053 HU and actively running a pair of Adire koda 6.5"s and Oz audio tweeters. Waiting on my break so i can get my 2 Soundsplinter RL-p 15"s in. I have 3 amps going in, Orion(tweeter and hopefully rear mids), Eclipse(mids) and an old RE35.1D amplifier(subs). It's about 2000 watts total when finished.

Your system looks fine. USAmps makes some nice amps and Kenwood should be ok. Install and listen first before you upgrade
 

·
Registered
Joined
·
246 Posts
I want a 35.1....those are some solid amps. I also miss my CD8053.

Have you looked at the Fi Q....same price as the RL-p and getting some really good reviews.
 
1 - 14 of 14 Posts
Top