Mazda 6 Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
4,138 Posts
Discussion Starter #1
Well my car still has the old program, and I have not had powerloss yet, but I will agree sometimes the power feels a little inconsistent, but I am hesitant to do the reflash as when the car is having its good days, its REALLY having its good days...

Anyways, all this RECALL talk, and I have not recieved a letter or heard anything from Mazda, where as other owners have reported getting letters in the mail...

Anyone else not hear anything???

Thanks....
 

·
Registered
Joined
·
378 Posts
I have not received one yet, however it is a new purchase. I bought it On July 29th, perhaps the letters went out before that.

Anyway I can tell if they did the reflash at the dealership before selling it to me?
 

·
Registered
Joined
·
4,138 Posts
Discussion Starter #3
Mine is an older purchase, from Feb. .....

You should have a sticker on your door if the reflash/recall was done...
 

·
Registered
Joined
·
320 Posts
I haven't heard anything from Mazda either, but mine is also a new purchase (7/24).
 

·
Registered
Joined
·
127 Posts
I did not recieve the recall letter and am starting to get aggrivated. I had the powerloss when i first got the car. then it didnt happen again. Well the last few days i have been having the powerloss like crazy. My dealer wants my car for a whole day day to do a 15 minute reflash. I cant afford to give my car for a day unless im getting another car in return. Even then im skeptical about givig up my car for a day. Ive seen some dealers do some crazy shit with customer's cars.
 

·
Registered
Joined
·
1,390 Posts
I got my letter last week and had my MS6 since first week of December...I'll get it done on my next oil change (should be next week or maybe this weekend)
 

·
Registered
Joined
·
428 Posts
I've had my ms6 since Nov and from what I've seen, the rest of the Canadians on this board havent gotten a recall letter. I did however go in and just get them to do the update for me anyways.
 

·
Registered
Joined
·
1,647 Posts
Well my car still has the old program, and I have not had powerloss yet, but I will agree sometimes the power feels a little inconsistent, but I am hesitant to do the reflash as when the car is having its good days, its REALLY having its good days...

Anyways, all this RECALL talk, and I have not recieved a letter or heard anything from Mazda, where as other owners have reported getting letters in the mail...

Anyone else not hear anything???

Thanks....
[/b]
Ls1gto got his ms6 dynoed with the flash. Looks healthy to me. 300 crank hp. I got the flash few weeks ago and very happy with it, its seems smoother and power is still there.

 

·
Registered
Joined
·
566 Posts
IIRC the recall specifically mentions cars up until April/04 mf date. Not sure why that's the cutoff since the newest flash came out in August?
 

·
Registered
Joined
·
1,022 Posts
Wig: Do you need the letter for something? I'll send you mine.

Bob: In April the update was intigrated into the new cars being built.

August was just the recall month, the flash has been available for months.
 

·
Registered
Joined
·
477 Posts
No, don't need a letter, just wondering why I didn't get one.... :(
[/b]
It may very well be that your car does not have the problematic flash. I think Mazda is being a little vauge on this recall as to whom is really effects. I received the notice for my car, but when I took it to the dealer, they said it had the correct flash already. My car runs on 91 only, has never had power loss, and I beat on the car in 100° weather all the time. The power is also very consistant in hot or cold weather, leading me to believe I do have the correct flash. BTW my car has a 10/2005 build date.
 

·
Registered
Joined
·
305 Posts
I'm in Canada - no power loss, no recall letter, and no sticker indicating any flash - build date 04/06. And I run 91 oct only...
 

·
Registered
Joined
·
721 Posts
No letter, no power loss, bought in April but i think build date was earlier.
 

·
Registered
Joined
·
36 Posts
No letter yet as I just got mine two weeks ago to the day. Build date is 4/06, experienced powerloss for the 1st time yesterday with ~2k on the clock while running 93 octane.
 
1 - 18 of 18 Posts
Top