Mazda 6 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter #1
So I got in my car here at my house went to start it and it only would turn once then stop. Wont start. My dials on my gauge cluster are going all over the place. Could it just be my battery or maybe something deeper. All the electronics work. so I dunno bout the battery. Please post quickly I gotta work in an hour and a half. Thank you for your help!!!


-ben
 

·
Registered
Joined
·
1,610 Posts
Guages going all over usually indicates the battery is so low that the computer and/or sensors can't function properly to calibrate the guages. Check your battery connections and get a jump. You may need a new battery...
 

·
Registered
Joined
·
91 Posts
Discussion Starter #5
yeah that is what I was guessing. the car is an 04 with 40k on it. Still original battery. hmmmm. How much is a decent battery and what do you guys recommend?
 

·
Registered
Joined
·
91 Posts
Discussion Starter #7
yeah but I am on a budget. Hadn't planned on buying a new battery. Can it be charged back up?
 

·
Registered
Joined
·
1,769 Posts
So what happened? You can always jump start it and go some more, but avoid short trips... itll still die soon but you may have some more life in it.

And yes, batteries can be charged, but bad batteries cant hold it hence the problem.

My car didnt want to start a few days ago. Just up and chug chug chug nothing. I tried for a few minutes... went inside for a sec, tried again and it jumped to right away without problems. Still have no idea why, like it just wouldnt fire...
 

·
Registered
Joined
·
91 Posts
Discussion Starter #10
yeah went to the parts store and the tested it only had 3.4 volts. Should have been 12. So I looked at their batteries and some how wieseled my way into a optima red top for 25 bucks! It had been used in a demonstration at the store therefore was called used. Never been installed in a car so I picked it up fast! Sweet!
 

·
Registered
Joined
·
497 Posts
yeah went to the parts store and the tested it only had 3.4 volts. Should have been 12. So I looked at their batteries and some how wieseled my way into a optima red top for 25 bucks! It had been used in a demonstration at the store therefore was called used. Never been installed in a car so I picked it up fast! Sweet!
[/b]
Nice deal man.
 

·
Registered
Joined
·
3,546 Posts
Optima makes a direct replacement battery for our car's.

It's a redtop, and the designation/part # is...model 34R.

It's rated with a CCA of 800. It's one rediculously beasty battery.
[/b]
I think I have that one, not sure, lol. But it isn't beastly in my opinion.

I still get that issue once in a while. Actually isn't the battery I guess, one time ground cable came out from an amp, so it was on all night, and most times the battery cables just dont hold well, so I changed them.
 
1 - 12 of 12 Posts
About this Discussion
11 Replies
9 Participants
PRacing
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top