Mazda 6 Forums banner
21 - 35 of 35 Posts

·
Registered
Joined
·
800 Posts
My question is if that seems to be the problem that is causing the symptoms as described?

Thanks

Tom
In theory, no. Turn signals do not work when the ignition switch is turned to the off position but the hazard lights do.
According to this diagram, hazard and turn signals are both controlled by that mystery box (flasher unit) so who knows, there could be a weird short happening in there sending power to one of the turn signals.
Go get one, it seems easy to replace and can't be that expensive, used.
243562
 

·
Registered
Joined
·
800 Posts
And here is how to test it... but I'd rather replace it then do this:

243563
 

·
Registered
2013 Mazda 6i Grand Touring - 2.5L I4 Auto
Joined
·
113 Posts
Any update?
Based on how he was answered and treated, I don't think we're about to hear anything more from that guy. I can't say that I blame him. I'm a Mazda owner and I'm often times frustrated with the lack of knowledge, information, or support that I find within the Mazda community, particularly as it relates to the 2G 6. Think about the number of people who have that phantom alarm going off all the time and not a single solution has ever been found. I think this could have been better handled. I think the Mazda community on a whole needs to do better. We need to get better informed and be more helpful to each other.
 

·
Registered
Joined
·
800 Posts
Based on how he was answered and treated, I don't think we're about to hear anything more from that guy. I can't say that I blame him. I'm a Mazda owner and I'm often times frustrated with the lack of knowledge, information, or support that I find within the Mazda community, particularly as it relates to the 2G 6. Think about the number of people who have that phantom alarm going off all the time and not a single solution has ever been found. I think this could have been better handled. I think the Mazda community on a whole needs to do better. We need to get better informed and be more helpful to each other.
I think the OP was provided with lots of useful info. I even took the time to search through the electrical manual to provide the best advice possible. @tango not sure what happened to you but I think this was not the place/thread to vent about it.
We do have some members with a short fuse but also many people post about an issue (not referring to this thread), don't even say "hi", "please help" or anything like it... they just write about their issue and many times not even post an actual question and then they don't even say "thanks"... like if they had been educated by chimps.... I am an admin in another car forum and I don't reply to newbies that don't salute or post an introduction and also don't hesitate to ban those that are rude or cause trouble. Forum etiquette does exist and gets you a long way.
 
  • Like
Reactions: Archerfish

·
Registered
Joined
·
2,471 Posts
I have passed the info on and the person is one that does not move quickly although getting to the flasher unit is a 5 minute job.

Tom
I got confused until I remembered that this isn't your car. Anyways, we would like to know how is this resolved in the future. It will surely be helpful to the community.
 

·
Registered
2013 Mazda 6i Grand Touring - 2.5L I4 Auto
Joined
·
113 Posts
Then why are you here? You basically just called us all know nothing assholes.
I'm here to help how and where I can. I never called anybody any such names, nor was it my intent. I'm sorry that's what you got from what I said, but I am simply stating that we in the Mazda community need to get to Honda and BMW levels of information gathering and exchange. But only when we recognize our deficiencies can we improve.
 

·
Registered
2013 Mazda 6i Grand Touring - 2.5L I4 Auto
Joined
·
113 Posts
I think the OP was provided with lots of useful info. I even took the time to search through the electrical manual to provide the best advice possible. @tango not sure what happened to you but I think this was not the place/thread to vent about it.
We do have some members with a short fuse but also many people post about an issue (not referring to this thread), don't even say "hi", "please help" or anything like it... they just write about their issue and many times not even post an actual question and then they don't even say "thanks"... like if they had been educated by chimps.... I am an admin in another car forum and I don't reply to newbies that don't salute or post an introduction and also don't hesitate to ban those that are rude or cause trouble. Forum etiquette does exist and gets you a long way.
I have no grouse with this board or anybody here. Nothing happened nor am I venting. I just read the responses and I thought some of the answers we gave the OP were rather curt. That's just my opinion on what I read. You did a fine job of assisting, no arguments there. I see that the OP has since responded and I stand corrected.
 
21 - 35 of 35 Posts
Top