Mazda 6 Forums banner
1 - 20 of 35 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Friend has 2008 Mazda 6 2.4 that has no running lights, fog lights or sunroof. Here is what has started to happen. When he turns the car off, the left front and back turn signal stay on solid, no blinking. (and of course, runs down the battery). No matter what he does the left turn signal lights stay on. He can more the turn signal stalk to turn on the right turn signals and they will intermittently work, but mostly not work. If he turns on the emergency flasher, then both sides will flash.

From my understanding of the system, the problem appears to be the "flasher control module" which seems to be an easy fix.

However the part is not found using that name and the Mazda dealer gave me the part # GP9B67750 which is listed as running lamps control module. 2006-2008 Mazda 6 Module GP9B-67-750 | Mazda-Parts

So what sounds like the problem and is that the correct part and name, although he has no running lights on the car?

Is there another name for that part that is behind the instrument cluster or is that the right part and is called that regardless of whether or not you have running lights?

Thanks for your time and help.

Tom in Dallas/Plano
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Sound like the BCM to me. Pull the neg cable for about a half hour, or overnight.
He has to pull the neg cable the light will shine all night and run down the battery. So that has been done 4 or 5 times. he has other cars he can drive. Why the BCM? What does it do?

Thanks

T
 

·
Registered
Joined
·
4,716 Posts
Check the relays under the hood then. I shorted something trying to wire the fog lights on my 2006 and had to run a wire to the relay for running lights to be on when the engine was running. But the BCM controls a lot including the sunroof which is why i said that first. The sunroof freezing is a known issue of a freaked out BCM.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #5 ·
Check the relays under the hood then. I shorted something trying to wire the fog lights on my 2006 and had to run a wire to the relay for running lights to be on when the engine was running. But the BCM controls a lot including the sunroof which is why i said that first. The sunroof freezing is a known issue of a freaked out BCM.
Thanks. This car has no sunroof, fog lights or running lights. What does that module do that is behind the instrument panel?

TBB
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #7 ·
I dont know what module youre talking about. You said it has a sunroof in it.
Orginally wrote: " Friend has 2008 Mazda 6 2.4 that has no running lights, fog lights or sunroof. " Not a big deal. Here is a video on the module.
What do you know about this?

Thanks

Tom
 

·
Registered
Joined
·
4,716 Posts
Orginally wrote: " Friend has 2008 Mazda 6 2.4 that has no running lights, fog lights or sunroof. " Not a big deal.
That tells me that you mean those three things dont work, cause all cars have running lights. Its a 2.3l.

Here is a video on the module.
What do you know about this?
Nothing, never knew it existed. I addressed your concerns with more likely reasons. Either follow the advice or dont, doesnt bother me.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #9 ·
That tells me that you mean those three things dont work, cause all cars have running lights. Its a 2.3l.


Nothing, never knew it existed. I addressed your concerns with more likely reasons. Either follow the advice or dont, doesnt bother me.
Sorry, no offense meant. I am just asking questions and know nothing of Mazda's but work on my own Jags and can tell you all about them. Thank you for your time.

TBB
 

·
Registered
Joined
·
798 Posts
Mine has every option available in 2006, including navigation... and its a V6.

But I think all should have the same module, I didn't know it existed.
Easiest way to find one is a junkyard, I bet every single Mazda 6 in there still has one on. Take the faulty one with you so you know the part has the same connector.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #13 ·
Mine has every option available in 2006, including navigation... and its a V6.

But I think all should have the same module, I didn't know it existed.
Easiest way to find one is a junkyard, I bet every single Mazda 6 in there still has one on. Take the faulty one with you so you know the part has the same connector.
My question is if that seems to be the problem that is causing the symptoms as described?

Thanks

Tom
 

·
Registered
Joined
·
2,432 Posts
Do you have any suggestions?

Thanks

Tom

I have very little knowledge and experience with this car, particularly a modern one. I came from a 98 model, although that CR-V is the top model during its time, but it has very few "brains". I think it only has one computer, unlike this Mazda having different modules.

An old school suggestion is, try to remove the bulb and clean the terminals. Hopefully, you find something unusual that might be the solution to the problem like a grounded wire. Another one is the fuse box. Perhaps there's a relay terminal that became permanently closed. I highly doubt it but it might be worth a try.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #15 ·
I have very little knowledge and experience with this car, particularly a modern one. I came from a 98 model, although that CR-V is the top model during its time, but it has very few "brains". I think it only has one computer, unlike this Mazda having different modules.

An old school suggestion is, try to remove the bulb and clean the terminals. Hopefully, you find something unusual that might be the solution to the problem like a grounded wire. Another one is the fuse box. Perhaps there's a relay terminal that became permanently closed. I highly doubt it but it might be worth a try.
Thanks. I am like you that I don't know about these cars. As I said before, if it were a Jaguar then I am in like flint.

TBB
 

·
Registered
Joined
·
2,432 Posts
If you suspect that the module is the defective, you might want to swap it for a working one and see if it solves the problem. I just don't know if there's a shop that will be willing to do that in your place.

Here in the Philippines, some automotive shops and/or surplus shops will allow us to test it by swapping the parts. If it doesn't work, we just return it.
 

·
Registered
Joined
·
4,716 Posts
This is the most basic as the 2008 Mazda 6, 2.4 can get. It has no fog lights, no sunroof and from what I know no running lights. So I do not think we have the same model.

Do you have any suggestions?

Thanks

Tom
Its a 2.3. You keep saying no running lights, what the hell do you mean by that? EVERY car has running lights/side markers/indicators. Its not even your car apparently? Why isnt the owner posting?
 

·
Registered
Joined
·
2,432 Posts
Its a 2.3. You keep saying no running lights, what the hell do you mean by that? EVERY car has running lights/side markers/indicators. Its not even your car apparently? Why isnt the owner posting?
He must have meant to say DRL for running lights. Now that you said that every car has running lights, I am now confused with the terms. Are automobile lights generally called running lights?

We call the lights at the rear as tail lights but I don't know what is it called when referring to the lights on the front. My friend told me that the lights around the car are called anti-collision lights. He might be joking when he said that because we were talking about airplanes during that time.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #19 ·
He must have meant to say DRL for running lights. Now that you said that every car has running lights, I am now confused with the terms. Are automobile lights generally called running lights?

We call the lights at the rear as tail lights but I don't know what is it called when referring to the lights on the front. My friend told me that the lights around the car are called anti-collision lights. He might be joking when he said that because we were talking about airplanes during that time.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #20 · (Edited)
Its a 2.3. You keep saying no running lights, what the hell do you mean by that? EVERY car has running lights/side markers/indicators. Its not even your car apparently? Why isnt the owner posting?
Maybe it does then. Be that as it may- is there any answer to the question of the original problem posted- running lights or not? Is it either the BCM or the running light/flasher control module behind the instrument panel?

Thanks
Tom
 
1 - 20 of 35 Posts
Top