Mazda 6 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello all, I’m new here and just bought a 2004 Mazda 6s from a auction for $325. The down call is that the radiator fans run constantly and when I shut off the car, it runs for another 20 seconds. I know that this is a common problem and theirs many posts regarding this issue but here’s my problem. I’ve change the FCM with a gates brand and now I can’t get the fans to turn on at all. So I replaced the temperature sensor thinking that might be it. NOPE. Still nothing. Then I looked at all the relays and fuses. Still nothing. So I put the old FCM back in, and now I’m back to the original problem of the fans running all the time. Anyone have any guesses why even with a new FCM, I could not get the fans to turn on without putting the old on in? Is their another sensor somewhere?
 

·
Registered
2004 Mazda 6 wagon 3.0
Joined
·
36 Posts
It's been a while since I replaced mine for the same issue, but I think I read that most aftermarket modules don't work or don't work for long. I got lucky and found one on Ebay from a dealership that was NOS. It was still expensive, but way less than the list price.
 

·
Registered
Joined
·
1 Posts
It's been a while since I replaced mine for the same issue, but I think I read that most aftermarket modules don't work or don't work for long. I got lucky and found one on Ebay from a dealership that was NOS. It was still expensive, but way less than the list price.
Did you just replace the fans only ? Or both at the same time Fcm & Fans. I’m having the same problem where they just constantly keep running as soon as the car starts. Thanks I’m advance
 

·
Registered
Joined
·
247 Posts
The gates module is junk. I had one fail after a few months, got a replacement under warranty. The new one did the same as yours right out of the box. You need to get an OEM Mazda one. Once I did that I had zero fan issues.
 

·
Registered
2005 6s Grand Touring Wagon
Joined
·
243 Posts
well, crap. I put a gates in mine. Fans don't come on nearly as often as before, but they do come on. No issues with overheating or anything. Only issue is outside temp reads high when idling. I guess I'll be looking for another now.
 

·
Registered
Joined
·
35 Posts
I bought this on Amazon, worked when I put it in, still works. No issues with it.
21 bucks isnt too bad compared to most.
edit
Installed in Feb of this year, so its been 7 months and weeks of 100+ days of heat.
 
1 - 6 of 6 Posts
Top