Mazda 6 Forums banner

1 - 20 of 26 Posts

·
Registered
Joined
·
2,536 Posts
Discussion Starter #1
the last 3 days when i have shut off the car and stepped out i still hear the fan running for like 10 seconds then shuts off, its pretty loud...yesterday it actually stopped started up again for like 2 seconds and then stopped...

this has never happended before.... also i think it sounded kind of funny when i started it... i dont want to start having problems, should i just take it to the dealer and be safe??

its a 2004 3.0L V6... i also have an aftermarket alarm w/ remote start installed, will the dealer blame that?? just want to be prepared because if their is something wrong i know they will try to pin it on me first...

all suggestions will be helpful, thanks....
 

·
Registered
Joined
·
1,780 Posts
Also I have a cp-e intake, aftermaket stereo, and viper alarm. Do you think any of that they will try to blame?
[/b]
The question isnt wether your mods actually had any effect on it, its sometimes HOW the tech can blame it on your mods.

Just to be on the safe side, I would un-install the CP-E intake when taking it in. I wouldnt worry about the stereo or alarm..... also make sure to print out the recall and take it with you.

Did the intake cause this problem, probably not, but can the tech attempt to blame it on the intake, probably. Always err on the safe side.
 

·
Registered
Joined
·
267 Posts
This happend to me a year ago, I took it into the dealer, they said its an reaccuring problem, so they updated the ECU with a new patch from mazda and I was out of there within an hour. They said nothing to me bout my mods. Has not happended since.
 

·
Registered
Joined
·
1,320 Posts
just take it in to the dealer they will replace the fan module.. ive had it done before i had my cp-e intake and everything and no problems. the intake has nothing to do with the fan module so if they give u problems just like punch em in the face or something
 

·
Registered
Joined
·
10 Posts
Hey guys,I'm new here but I think i may can help you guys.I am a service manager at a mazda dealer.the fan control module is your problem with the fan running,it's not uncommon with the six,there is a bulletin out on it.If your still under your factory warranty then of course it won't cost a dime but if not then depending on what your dealer charges per hour it should be around 100 bucks.
 

·
Registered
Joined
·
165 Posts
I read through all those posts...
My 6's fan has always run for anywhere from 10-30seconds after the car has been shut off. I thought that this was normal as I've had other cars do this. I was always told that it helps cool off the warm engine in a more consistent manner and was somehow good for the engine.
Is this the symptom that everyone says should be remedied by the replacement of the module?
 

·
Registered
Joined
·
165 Posts
And of course as soon as I see this thread and ask about it... last night the fans stayed on for a few minutes after shutoff.
And they seemed louder... :swearin:
 

·
Registered
Joined
·
165 Posts
I again wanted to thank those on this board. I went to the dealer and had them replace the fan module today.
I was nervous, since this was the first time I brought it in for a warranty issue with the Injen/MAF customizer installed and was worried they'd give me some shit about it. (they had given me some grief when I installed the exhaust/Injen on my Protege5)
Not one word about it. :nono:
And not only were they quick about it, they did it without disconnecting my battery and resetting all my electronics.
AND... they found that my brake lines had a bunch of bubbles. I thought that the noise every time I pressed on the brake pedal was just a noise from the pedal brushing against something. Apparently, it was a real issue. I can't believe I didn't feel the difference!
 

·
Registered
Joined
·
366 Posts
Ok, my fan has just started to do this these past few days. The fan would still run after the car is off. Ive read this thread, so it seems that i need to replace my fan module now? I got over 46000 miles on my car now. My warrenty is gone pretty much, so is this going to be expensive? I have a 03 V6 by the way.
 

·
Registered
Joined
·
164 Posts
Ok, my fan has just started to do this these past few days. The fan would still run after the car is off. Ive read this thread, so it seems that i need to replace my fan module now? I got over 46000 miles on my car now. My warrenty is gone pretty much, so is this going to be expensive? I have a 03 V6 by the way.[/b]
If your warranty has passed you can purchase a fan module from one our sponsors here. The price has dropped dramatically since I purchased one last year for around $100. Currently it's $22.24 with Sabrina.

JimClickMazda
 
1 - 20 of 26 Posts
Top