Mazda 6 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
I'm aware that there are numerous reports of FCM issues & a TSB for 03/04 6cyl 6's - I have not seen or found in search specific reporting of FCM issues on 05's & 06's?

I have an 05 ATX Wagon with 14.5K miles that is having cooling fan issues.. more often with the AC on but happens with AC off as well... cooling fan will rev up and stop or when shut off she revs, doesn't get going and tries a couple of times...before giving up.

I'm bringing to dealer tomorrow morning. i have a feeling the service dept will be ware of the issue - any one else with 05/06 having cooling fan issues?

thnx...
 

·
Registered
Joined
·
27 Posts
Discussion Starter #2
totally Fan Control Module - replaced by dealer in 30 minutes - running fine now. We'll see if this is an updated FCM - or how long it'll run well before failing again...

:drive:
 

·
Registered
Joined
·
26 Posts
I have an 05 V6 and had to have mine replaced a few days ago, fans revving up and A/C not working properly, seems OK now.
 

·
Registered
Joined
·
1,687 Posts
mine has been acting this way for about 2 weeks now. I hope to be getting rid of the car and getting a speed by the weekend if not then while i am at the dealership will have them fix the problem. I assume this is a warrantee issue right?
 

·
Registered
Joined
·
27 Posts
Discussion Starter #5
mine has been acting this way for about 2 weeks now. I hope to be getting rid of the car and getting a speed by the weekend if not then while i am at the dealership will have them fix the problem. I assume this is a warrantee issue right?
[/b]
repaired under warranty ... 30 minutes ... easy...
 
1 - 5 of 5 Posts
Top