Mazda 6 Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
3,431 Posts
Discussion Starter #1
Any of you guys get this problem yet? My car has had the damn engine light come on twice an i JUST went over 1000miles this week in it. They told me it could be the gas cap and all this other crap but i checked it an it stays on. The first time i took it to the service shop here in town, and when i got back to pick up my car they told me the light wasnt on and nothings wrong with it.

Yesterday just driving down the street to mcdonalds on my lunch break at work i looked at the dash an sure enough it was on again. Nothing seems to be wrong, gas cap was on fine. I drove around all over today and the thing stayed on the whole time. Looks like im gonna have to go back to service tomorrow morning if the light stays on still...

Anyone else have this problem yet?
 

·
Premium Member
Joined
·
2,898 Posts
Reading Topic: Engine Light On..?

I think there were several other posts on this. Mazda was having a problem with some of the vacuum lines coming lose that was throwing the CEL. Check those lines yourself (or have you dealer do it) to see if that's causing it. If it still does it, MAKE the dealer do a full diagnosis to see what code the CEL is giving.
 

·
Premium Member
Joined
·
3,997 Posts
Reading Topic: Engine Light On..?

A bunch of people on here had a vacuum line problem, search a good ways back in the Engine forum to find a better description of the problem. Last I heard, dealers were replacing it for free.
 

·
Registered
Joined
·
3,431 Posts
Discussion Starter #4
Reading Topic: Engine Light On..?

ok guys thanks ill look into this!
 

·
Registered
Joined
·
142 Posts
Reading Topic: Engine Light On..?

my engine light is on right now, and its been on for about 2 weeks now :(

I went to the dealer, they said that cylinder #4 was misfireing, and the coil was bad, so they ordered a new coil, it comes in on the 7th, so only a few more days of this annoying light.

Bring your car to the service people and ask what code it is reporting, even if the light is off, the code stays in memeory so dont take any shit from them.
 

·
Registered
Joined
·
209 Posts
Reading Topic: Engine Light On..?

i had the same problem with my 6i, they said MazdaUSA was having software programs in the ECU, and about a month ago they updated the software. Havent had a problem since
 

·
Registered
Joined
·
1,059 Posts
Replying to Topic 'Engine Light On..?'

QUOTE
Originally posted by RacerX


            my engine light is on right now, and its been on for about 2 weeks now :([/b]
lol. talk about taking your time :D At least Mazda has a loaner car program for these situations.
 

·
Registered
Joined
·
895 Posts
Reading Topic: Engine Light On..?

I haven't had a single problem with my car yet. *knock on wood*

Hope I'm one of many lucky ones. :/
 

·
Registered
Joined
·
126 Posts
Reading Topic: Engine Light On..?

Speaking of loaner cars... my last loaner was a piece of crap. A 16,000 mile rental Ford Focus that felt like it had 80,000 miles on it. The alignment was off, the door seals were leaking air, the seats were uncomfortable.

Those of you who have gotten a loaner, what car did they give you? I'd think they should give me something at least as big as the 6, right? I'm thinking of switching dealers now.
 

·
Registered
Joined
·
1,059 Posts
Replying to Topic 'Engine Light On..?'

QUOTE
Originally posted by Spiff


            Speaking of loaner cars... my last loaner was a piece of crap.  A 16,000 mile rental Ford Focus that felt like it had 80,000 miles on it.  The alignment was off, the door seals were leaking air, the seats were uncomfortable.

Those of you who have gotten a loaner, what car did they give you?  I'd think they should give me something at least as big as the 6, right?  I'm thinking of switching dealers now.[/b]
My dealer told me they rent you a car from the Enterprise RAC down the block. So I would imagine something like a Grand Am in my case.
 

·
Registered
Joined
·
126 Posts
Reading Topic: Engine Light On..?

Moocat, that's where mine was from. Enterprise. Shouldn't it have been a bigger car?
 

·
Registered
Joined
·
1,059 Posts
Replying to Topic 'Engine Light On..?'

QUOTE
Originally posted by Spiff


            Moocat, that's where mine was from.  Enterprise.  Shouldn't it have been a bigger car?[/b]
prolly not, i would imagine they rent you the cheapest car possible.
 

·
Registered
Joined
·
1,667 Posts
Reading Topic: Engine Light On..?

i had to have my ECU relfashed today also (5-20-03) i had a CEL come on this SAT after i got gas... they told me today it just needed to be reflashed and that was all. i'll scan my paper work from today to show u guys wut wut done. it had me bummed out to have my 6 have a CEL.
 

·
Registered
Joined
·
541 Posts
Reading Topic: Engine Light On..?

I had the CEL come on the second day I owned the car. The dealership said it had somethign to do with the VVT but they didn't know because Mazda didn't give them all the diagnosing sftware they needed. The engine ran fine, and the light went out the next day. It's been 1 month and 4000 miles since then and I haven't had a problem with it since.
 
1 - 15 of 15 Posts
Top