Mazda 6 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
OK, I don't know if this is a stupid question or not. But, is it possible to put an '03 engine out of an automatic in an '04 manual?? same engine 3.0l v6.
 

·
Registered
Joined
·
826 Posts
As long as it fits and hooks up, I guess so....? The drivetrain is the difference between auto and manual not the engine....?

I don't know, I'm not a huge engine expert.

May I ask as to why you are putting in a 03 engine?
 

·
Registered
Joined
·
703 Posts
yes
 

·
Registered
Joined
·
58 Posts
Discussion Starter #4
Reason i ask is my engined in my 04 took a crap @ 58K miles. The engine i bought was out of an 03 and it only had 6K miles on it. When the Mech dropped it in, the wiring harness was a little different so he swapped th em. Now, my Traction Control Sys. isn't working, thowing a CEL for variable cam timing sensor on both heads, and rpm wants to go to 500 or less and fluxes..........It's a pain in my ass......
 

·
Registered
Joined
·
826 Posts
Reason i ask is my engined in my 04 took a crap @ 58K miles. The engine i bought was out of an 03 and it only had 6K miles on it. When the Mech dropped it in, the wiring harness was a little different so he swapped th em. Now, my Traction Control Sys. isn't working, thowing a CEL for variable cam timing sensor on both heads, and rpm wants to go to 500 or less and fluxes..........It's a pain in my ass......
[/b]
Update the ECU and maybe somethings wired wrong? The traction control not working is the reason why I say change the ECU.
 

·
Registered
Joined
·
2,398 Posts
i blew my 03 engine and it has an 04 in it. The gu that did it was very very good at what he does. This was about 3 years ago now. We did not have any wiring harness problems at all. May be just missing some connections.
 

·
Registered
Joined
·
449 Posts
My question would be did you swap just the block itself or everything connected with it? The thing that makes me concerned is the fact that he said the harness is different. Some sensors and other items can be different from year to year. Also, a different harness may fit into an older one but it doesn't mean the connectors in it are all in the same spots. The computer is also a little different each year as it receives tweaks and other minor modifications from Mazda.

I had this problem when i swapped a GM 3.1 a few years ago. We stripped the block and heads and reused everything else off the stock engine. This got rid of all the problems.
 
1 - 9 of 9 Posts
Top