Mazda 6 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi! I bought an 03 mazda 6 a couple of days ago. When I bought it every thing worked great. Yesterday the radio, A/C, rear defrost, and air circulation controls stopped working and I can't figure out why. Any ideas?
 

·
Rally Racer
Joined
·
2,066 Posts
Hi! I bought an 03 mazda 6 a couple of days ago. When I bought it every thing worked great. Yesterday the radio, A/C, rear defrost, and air circulation controls stopped working and I can't figure out why. Any ideas?
The first place is to heck is the fuses. Second, it is possible the radio/console was removed and not reconnected properly. Pull the radio and see if one or more of the connectors has come loose in the back. Don't forget the security bolt behind the glove box. If you drop it it will pass into another dimension so be careful.
Good luck.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I checked the connections behind the radio and they are all connected and all the fuses are fine. Any other ideas?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Update- I fixed the AC. It was i deed the ROOM fuse. When I had checked it previously it looked fine with the lighting I had. However the radio still doesn't turn on. It is an after market system and I am going to check some other fuses tomorrow.
 

·
Registered
Joined
·
41 Posts
Nice keep checking the fuses, room controls the radio and interior lights etc. Just because a fuse looks okay doesn’t mean it is conducting through itself, the metal prongs could be damaged or corroded. You can use a multimeter to test them out of the vehicle to make sure it’s working properly. You can also buy a “fuse tester” I believe it is, cheapo tool from auto parts store or walmart. If all else fails you can check for power at the radio harness with a multimeter as well. Good luck troubleshooting let us know what you find out! My car did about the same when I first got it home, it was on the fritz when I test drove it and then not at all the day I took it home. I ended up not having climate controls properly or the radio, some of the leds working. I replaced the radio head unit with the same model number off of eBay and it solved all my radio issues after I had fixed any fuses.
 
1 - 6 of 6 Posts
Top