Mazda 6 Forums banner

121 - 126 of 126 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #122 (Edited)
Evening all, I got my car back yesterday afternoon. Mazda carried out the replacement of the EGR cooler. I can say with a high degree of confidence that this issue is finally fixed! I've been driving around a lot since I got the car back, constantly checking for DTCs. None found. In every case before this, there was always a parked P0401 'pending' or 'archived' error, followed by an active error. It has been code free the last 2 days which has never happened since I bought the car over a year ago.

@Jay at was spot on when he recommended getting the EGR cooler cleaned however, it seems that the mechanic I took it to did a very poor job cleaning it. This is why I asked him to remove it and give it to me so I could clean it thoroughly. I think it was just laziness/sloppiness on the mechanic's part and I won't be going back to him again. That is 6 garages I have been to and only one of them even remotely diagnosed it properly, but he had no interest in taking the job.

The Mazda dealership have been absolutely outstanding. I think it helps that my car has almost a full service history with Mazda. They must have spent over £2,000 doing goodwill repairs well outside the warranty period. Superb service!

So if anyone comes here with the same error for the same car/engine, then a good recommendation would be to take it to a COMPETENT mechanic who can remove the EGR valve and clean it PROPERLY. Not half arsed like the clown I took it to. Better still, take it to the main dealer and get a proper diagnosis. It will save you a lot of hassle in the long run.

I hope @Jay at comes back to see this. I know he has been following this thread from the start and has been an immense help. Thank you to everyone else for their comments/ideas. Fingers crossed, this is a fix!
 

·
Registered
Joined
·
66 Posts
Discussion Starter #124
Hi folks, it's been 6 weeks now and all is well. Just thought I would post an update. Thanks :)
 

·
Registered
Joined
·
1,759 Posts
Hi folks, it's been 6 weeks now and all is well. Just thought I would post an update. Thanks :)
I think we can safely conclude that what you did fixed the issue. Congratulations!


My question now is, how can I prevent this from happening? The issue is the EGR cooler, right?
 

·
Registered
Joined
·
66 Posts
Discussion Starter #126
I think we can safely conclude that what you did fixed the issue. Congratulations!


My question now is, how can I prevent this from happening? The issue is the EGR cooler, right?
Yes, I'm very confident that is a fix 🙂 Yes it was the EGR cooler. I'm still convinced that if it was cleaned properly then that would have fixed the fault too.

I would say good practices should prevent it. Diesels don't like short distances all the time so if you live in a city with short journeys, that does not allow for proper DPF regeneration etc. With a properly serviced engine, regular oil changes at least every 6 months/6-8,000 miles or so and good driving habits, hopefully this won't be an issue for most. :)
 
121 - 126 of 126 Posts
Top