Mazda 6 Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Been dealing with egr codes ( stuck valve and insufficient exhaust gas circ). Tried cleaning and then replaced egr valve as well as cleaning the pipes and intake with carb cleaner. CEL still coming on. Anybody know how to check the electrical connector ( harness side) also is it worth taking pipe off the exhaust end down below? Seems unlikely to be clogged there and I can’t seem to get enough leverage to crack the bolt.
main concern is passing emissions. It runs well enough
thnx
 

·
Rally Racer
2004 Mazda 6s Wagon ATX
Joined
·
3,729 Posts
Been dealing with egr codes ( stuck valve and insufficient exhaust gas circ). Tried cleaning and then replaced egr valve as well as cleaning the pipes and intake with carb cleaner. CEL still coming on. Anybody know how to check the electrical connector ( harness side) also is it worth taking pipe off the exhaust end down below? Seems unlikely to be clogged there and I can’t seem to get enough leverage to crack the bolt.
main concern is passing emissions. It runs well enough
thnx
Is this a P0401 and P1487? knowing which engine you have and what codes will help us help you. Otherwise you get answers like check the connector with a multi-meter.
If the EGR passage is clear I am willing to bet, (with knowing almost nothing about your situation) the EGR boost solenoid is bad.
🤷‍♂️
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Is this a P0401 and P1487? knowing which engine you have and what codes will help us help you. Otherwise you get answers like check the connector with a multi-meter.
If the EGR passage is clear I am willing to bet, (with knowing almost nothing about your situation) the EGR boost solenoid is bad.
🤷‍♂️
yes code p0410 and p0401 . 3.0l engine. Already replaced the solenoid valve
 
1 - 3 of 3 Posts
Top