Mazda 6 Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
165 Posts
Discussion Starter #1
Hope this is the right area for this.....

For the last week, my '06 6S MTX started acting up. Whenever I got up an incline, (small or large) it feels like a compression issue. (My old car lost compression so I know what it feels like). Weird part....no CEL. Nothing. Then, after a few seconds, it corrects itself. I tried it with and without the heat on (to see if the extra strain had anything to do with it) - no difference. When I drive it on a normal, flat road it's good. At idle, no problems either.

I'm taking it in on Fri (the soonest they can get me in). Any ideas? Since it's fine 95% of the time, I was doubting MAF or hoses, since it would happen more regularly. Been a few fillups, so I doubt bad gas...again, it would've happened more too. I'm guessing a bad sensor giving wrong gas amounts to engine? Or maybe transmission?

Any ideas or suggestions would help.

Thanks

Edit: I have no mods on the engine or transmission...all stock.
 

·
Registered
Joined
·
487 Posts
how many miles on the car? and is the gas tank full/empy when this happens?

The pump is supposedly suspectable to clogging of the filters, but you got an 06...
 

·
Registered
Joined
·
165 Posts
Discussion Starter #3
how many miles on the car? and is the gas tank full/empy when this happens?

The pump is supposedly suspectable to clogging of the filters, but you got an 06...
[/b]
11,000....happens sporatically. Half-tank....quarter. Not as if it's too low to cause issues if the tank level was slanted uphill. But I see what you are saying.
 

·
Registered
Joined
·
487 Posts
well, you got under 12k, which means your in the adjustment period too, and the dealer *should* be nice to you. just take them for a ride and reproduce the problem. If they say yea, i see it but it's normal, then just say let's take a brand new one on a ride and see if it does it. If the new one does the same (which it shouldn't right?)
 

·
Registered
Joined
·
165 Posts
Discussion Starter #6
Is the AC/defroster kicking on/off? That will rob a few HP.
[/b]
Nope...although cold...I turned everything (heat, ac, re-circ) on & off, and at different settings. No reason though, why a V6 cant go up a hill and lose power to the point of almost bucking/conking out.

I'm starting to wonder maybe TPS?
 

·
Registered
Joined
·
235 Posts
Nope...although cold...I turned everything (heat, ac, re-circ) on & off, and at different settings. No reason though, why a V6 cant go up a hill and lose power to the point of almost bucking/conking out.

I'm starting to wonder maybe TPS?
[/b]

I dont know if this is what happening to you, but my driveway is about a 15 degree slope and pretty long. Somtimes when i go up, i notice Clutch Judder pretty bad. Sounds like it could be my engine but i know its the clutch. I rarely get judder on flat pavement, just when im trying to get up a steep hill starting off in first gear.
 

·
Registered
Joined
·
1,320 Posts
so what happens exactly when your trying to go uphill? im not understanding whats going on exactly.
 

·
Registered
Joined
·
165 Posts
Discussion Starter #9
I dont know if this is what happening to you, but my driveway is about a 15 degree slope and pretty long. Somtimes when i go up, i notice Clutch Judder pretty bad. Sounds like it could be my engine but i know its the clutch. I rarely get judder on flat pavement, just when im trying to get up a steep hill starting off in first gear.
[/b]
Hmmm...only 2 things about my situation is (a) never happened before on the same roads, and (b) its when im already driving (2nd, 3rd or 4th gear).

But I appreciate all the input! Keep it coming!
 

·
Registered
Joined
·
165 Posts
Discussion Starter #10
Ok....got back from dealership. Couldn't replicate issue (lol)....but there was a reflash that fixes some of those issues. We shall see. Thanks everyone for the ideas!
 

·
Registered
Joined
·
1,106 Posts
I took my 03 MTX 6s into the ozarks a few months ago... It was a blast. I had no power loss, I went up some pretty steep stuff with out a problem. I did have to down shift to 1st gear to go around the corners that went up, but man was it fun. I hope they get your problem worked out.
 

·
Registered
Joined
·
1,320 Posts
i had an issue just like this and some of my ignition coils went bad. tell your dealer to run diagnostics on all your ignition coils.
 
1 - 13 of 13 Posts
Top