Mazda 6 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 2005 Mazda 6 S (3.0) MTX


I feel really stupid at the moment, and I'm sure I'm just missing something obvious but does anyone know where this goes? I am in the process of putting my car back together after changing the clutch, but I can't for the life of me remember where this little connector goes. I've tried looking up some sort of wiring diagram to no avail, but it appears to go down towards the transmission and is attached to the same wiring of the plug/ground that attached to the transmission itself. I feel like I've looked all over but can't find anything that it will reach/fit into. I don't see any plug like that on the starter, and I do think there is anything around the shift linkage deal and it appears to naturally go down towards the side of the transmission and not up towards where I have it pictured. Any help is much appreciated. I thought I documented all of this as I was taking it apart but I was also drinking for a lot of it so I am not surprised I forgot. To be honest I don't really remember where any of that stuff goes on that side of the tranny. There's a ground type wire with the rubber protector over it in this pic to the left and I am not sure where that goes (I think the bracket by the shift linkage,) I also don't know if that ground that's currently bolted to the tranny right there as well is in the correct location either. I'm a major noob when it comes to cars and an even bigger one when it comes to electrical stuff no idea why I didn't take pics or a video on this portion of the disassembly. If anyone has a diagram or something along those lines it would be great.


238867
 

·
Super Moderator
Joined
·
16,876 Posts
Sorry I didn't see this earlier - It looks like it could be an O2 sensor plug, but I'll have the experts confirm: @DrFeelGood @DJ Raydiate :)
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Thanks for the replies guys, I'm gonna try to knock the rest out today and will see what I can figure out. I know the white one goes to the starter, so maybe I'll just put the starter back on now and see if anything obvious appears then. Judging from your picture I believe I might have the 3rd one you listed in the right spot where it is (I left the bolt in it and I found one spot where the bolt went in and that looks to be about it.) I'll put the rubber boot on the starter as well, I'm pretty sure that's why I didn't document where it went because I thought (shows how dumb I am) it would be easy to remember. Now it's just a matter of finding out where that connector/plug goes that someone mentioned might be an o2 sensor
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
So just for anyone else that might run into this problem, there are two connectors that connect to the tranny. One is right next to a ground down the right side of the tranny (if you’re standing on the driver side of your engine bay) but it’s closer to the engine itself, and the one that I originally posted about is right underneath the linkage assembly. You’ll have two links that have paper clip looking locks and it’s right below them. No idea what it actually does but that’s where it goes lol. Thanks for the replies!
 
1 - 5 of 5 Posts
Top