Mazda 6 Forums banner

1 - 20 of 43 Posts

·
Registered
Joined
·
384 Posts
Discussion Starter #1
Grounded my car, in a daisy chain...i used the NRG kit...but did it diff then most people...i di dnot use a central hub point...as well i moved the crank sensor as far down as it went...

Well i did both mods in the same day...here is the result....

no more CEL from my AEM CAI...used to come on n off...now its not comin on at all...been over a week already...usually came on every other day...now no more...

also...rpm drops extremly slowly now...i mean extremly...

like i m drivin in fourth...pull up to a light...depress the clutch...engine drops to like 1500rpm...waits ther for a few secs...n then slowly over like 5secs, starts droppin down to the normal 750 range...but like u can see the gauge slowly slowly dropping...and that is new...big time new...was nto like that b4 at all...not sure if its from grounding or from crank sensor...

but the car now drives so much better...i mean...it has so much lower end grunt...bare in mind i use Esso89...so that has some effect on performance...at least on my car...
ohh ya, one more thing...the throttle lag that i had...is gone...ther is instant response now...and i mean instant...like its cable driven...

i also lowered my front with eibach pro's...and installed tokico's on front two weeks ago...n just finished the rear shock install last nite...here is the result...

i used to have serios clutch judder...its totally gone now...i m thinkin the only explanation i have, is the angle of the shafts has changed. nothin else...cuz installin the stainless steel braided clutch line jsut improved the feel of things, but the judder was still there...but now that i installed the springs...its totally gone...so i m really happy...

the car is extremly tight now...i also have the RB rear sway installed as well...so that helps out big time...the tokico rears are really really stifff...when i installed the front spring/shok combo..wasnot nearly as noticable a diff as jsut the rear shocks alone...

but over all...this is what the car shoudl have been like from factory...exxtremly tight...amazing power...and extremly balanced...no more brake/acceleration dive...no more leaning in corners...this is what its meant to be like...

i m really happy with results...

p.s.: for those who will try n install the front shocks...a word of advice...have a huge long crow bar ready, in case u cant get the fork screw off at the bottom of the suspension...i could not get that screw off for nothing...so i had to do it the long way...and compress the shock manually with a crow bar jsut to take it out....a big time pain... so jsut be warned...the rust can be a big pain...

CLaman...here soem pics for you ;)


notice that only front is lowered...so the front fender gap is bout 1/4 less then back now ;) perfection...jsut what i was aiming for...






now its perfect height, ride n control
 

·
Registered
Joined
·
807 Posts
Factory tint would be nice 2, looks good!
 

·
Registered
Joined
·
1,401 Posts
y would u lower ur car now?
 

·
Registered
Joined
·
635 Posts
Looks awesome !!! love the rims + tint ... I agree dropping just the fronts work well, the rear is low enough ..
 

·
Registered
Joined
·
2,664 Posts
I'm glad the tools helped out serge.

If anyone needs any help with doing anything to our cars just send me a PM.
 

·
Registered
Joined
·
3,226 Posts
Looking good Serge. So, your rears are Tokico HPs with stock springs?

And, see, I told ya grounding kit made a difference :)
 

·
Registered
Joined
·
384 Posts
Discussion Starter #12
minor edit...

blue6 i dropped the front cuz its only 1.5" lower...and it will still clear all the snow i would ever encounter here in the Wopbridge ;)

as for grounding kit...i will take soem pcis n edit the first post...gimme til later 2nite...after work...

ohh ya, CEL came bak yesterday...dotn knwo y...so i guess grounding did not get rid of it...

but there is something that bothers me...i did the crank sensor mod same day as the grounding kit...my fuel economy dropped like crazy...alsmot 50%...sure the car pulls like crazy...but it swallows fuel by buckets...also the sound of the engine changed...its a much lower gruntier sound...i m not sure i like the side effects...the fuel econo was my major reason for bein so happy with this car...now i m disspointed...big time...even on highway, i cant get past 500km now...

so i m gonna go n move the sensor back to the original place, n hope that the fuel econo goes back up...fingers crossed...

zoomzoomfan, yes i have stock springs on tokico blues rear
 

·
Registered
Joined
·
384 Posts
Discussion Starter #14
thanks to all for compliments...
 

·
Registered
Joined
·
2,664 Posts
Serge have you tried putting in a higher octane fuel. Try that before you move the sensor back.
 

·
Registered
Joined
·
384 Posts
Discussion Starter #16
ya higher octane is the first thing i did...i ran a tank of esso91, an barely reached 500km, altho the car drove amazingly...
now i m running on esso89 as usual...the car still has power..but not as much down low...but the economy dont seem to have improved...i m half way down the tank, only at 330km...
 

·
Registered
Joined
·
160 Posts
ya higher octane is the first thing i did...i ran a tank of esso91, an barely reached 500km, altho the car drove amazingly...
now i m running on esso89 as usual...the car still has power..but not as much down low...but the economy dont seem to have improved...i m half way down the tank, only at 330km...
[/b]
Hm, I'm pretty much seeing similar number with my stock i4..

When it's not cold outside, the needle starts leaving the full line at around 50-60km, hitting first quarter from the full line at ~150km, and half tank at about 350km.

When it's getting colder, like right now, i'm getting ~120kms at first quarter from full, and around 300+ at half tank.

This is all with 87 octane. Manual, loaded hatch. Mixed highway and city driving. If I go for a longer road trips, I'd maybe get ~400 for half tank.

Not sure what numbers were you getting before, but it doesnt look too bad to me for this time of year, assuming you drive mixed city/hwy.
 

·
Registered
Joined
·
384 Posts
Discussion Starter #18
for me the the needle used to leave the full mark at bout 100km, and reach the half point at 425-450...and then reach empty towards the 775km mark...
 
1 - 20 of 43 Posts
Top