Mazda 6 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
So I took my 2005 Mazda 6S 5speed into the dealer on satuday, got around to looking at it today finally. My issues are, play in steering, wheel doesn't respond right away when turning, loss of assist, pulling when braking and accelerating.

--------------------------------------------------------------

9:30am First Call:
Dealer: "We looked at your suspension and drove it, everything is perfect, BUT your brakes need replacing badly!"

Me: "brakes are fine, you need to redrive it, something is definately wrong"

Dealer: "Ok we'll take it back out"

--------------------------------------------------------------

3:00PM Second Call:
Dealer: "yes I felt the issue, it is really bad, theres like a 1/4 turn play in the wheel, it pulled right under braking and when corrected, pulled left, the power assist felt like it went out."

Me: "ok so whats the problem?"

Dealer: "i dont know, I can't get it to happen every time"

Me: "Ok?"

Dealer: "I'll take it out again"

--------------------------------------------------------------

5:00PM Third Call:
Dealer: "I can't reproduce the issue"

Me: "well ok I'll pick it up, I'm not paying the $99.00 service fee"

Dealer: "thats fine"

Me: "ok i'll pick it up tomorrow, can you take it out again tomorrow and check again"

Dealer: "certainly"

-----------------------------------------------------

Damn dealers, anyone have these issues, I really feel its the steering rack, I've heard of others needing the rack replaced for similar symptoms, anyone have these issues?

Thanks
 

·
Registered
Joined
·
113 Posts
It sounds maybe the rack and pinion. Maybe check the ball joints and a arms. My girlfriend had a stratus years ago with something similar tot he steering and her arm broke which in turn, pulled her axle out of the trans and busted shit. She was in around 2500-3000 worth of work
 
1 - 3 of 3 Posts
Top