Mazda 6 Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
So 2 days ago i installed the cp-e intake that i bought off a member on this club. First of all, the install was a pain in the ass. I installed both a cold air intake and ram air duct on my former rx8 and the installs were significantly easier and quicker, even with bumper removal. The directions were better too. From all the comments ive read on this club about the cp-e, i thought install would be a breeze. But whatever, its installed now.

Now onto the sound. It sounds wierd. From what i read, i was expecting to hear a whoosh sucking sound while getting on the gas and the BOV. I hear the bov now, and i also hear a whoosh/sucking, but its louder and much different than i thought it would be. When i was installing the filter at one point i thought it was on tight until i gave it a slight pull and it came off, then i spent like 5 min making sure it was on tight. From like 1.5k to 2k theres a reall wierd sucking sound. Additionally, when i initially blip the throttle, theres a whoosh/pop, which i think is normal. The thing is, the SOTP pull feels better, so that makes me believe the install is correct. 1st and second gear really do feel better. However, when i pressed the gas in 5th gear at like 40mph, the pull seemed worse than before the install. Anyone else feel this?

Im going to recheck the filter tomorrow and make sure its tight. Do you guys think this is just what the intake sounds/feels like, or did i screw up? I checked the tubes and piping and its tight so i really dont know whats up. Im a young guy, so a slightly loud intake isnt a problem for me, but, to tell the truth, it sounds so wierd that im somewhat disappointed, especially in the lower rpm's.

your responses are appreciated.
 

·
Registered
Joined
·
1,498 Posts
Everything actually sounds about right. I can't attest to the specific sound of the CP-E (mine is a mazdaspeed cai), but I too was surprised at what the intake sounded like on this motor.

As for the 5th gear pull, reset your ecu by pulling the battery cable (which hopefully you did during the install) and wait a few drive cycles for the short term fuel trims to reset.

Good luck to ya
 

·
Registered
Joined
·
329 Posts
Sounds like it's installed correctly. The sound is surprising at first but becomes quite addicting. I still can't get enough of hearing the turbo spooling up in this car. I haven't a clue why your car wouldn't feel like it was pulling hard in 5th.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
so i just drove it. and it feels better and sounds better than yesterday. to tell the truth, i really like it. it still sounds somewhat weird to me but i hope nothings screwed up. Yesterday it was better than the day before as well, so yea, i guess the ecu is relearning. and yes, i did unhook the battery during installation.
 

·
Registered
Joined
·
1,256 Posts
i recently installed mine 3-4 days ago and at first the sound i thought was wierd cause my friends all have injens's and AEM CAI's so the sound is more gruff loud. I thought i installed it wrong to cause the first day sounded not normal, but 2 days later i am addicted to the sound. I feel the power alittle more and the sound is sweet. You will deff get lead foot happy when you are in tunnels or under bridges like i am. Can you hear your stock BOV now to. Mine is so much louder when i switch in 3rd and 4th gears, 5th gets alittle quitter. It takes time to sound better and grow on you though. Next is hopefully DP =)
 

·
Registered
Joined
·
18 Posts
Discussion Starter #7
I just drove it again and it feels great. the sound is still strange though! i can hear 2 distince tones of sucking/whoosh. one lower pitched one higher. maybe thats just te turbo spooling and the intake sucking. however, it sounds like both sounds are coming from the intake.
 
1 - 7 of 7 Posts
Top