Mazda 6 Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
These passed 2 weeks i've been noticing my transmission, supposedly, has been still going even after i turned off my engine, which reminds me of the ford escort my parents used to have. Is that what it is cause i didnt notice this problem last summer when i had it, and i've been looking around this board and i see a lot of cooler transmission posts, so i'm gettting the idea that that what is causing it. If it is how much does this take to fix???
 

·
Registered
Joined
·
823 Posts
Your transmission is going on?

Do you mean the fans?

Because many have mentioned the fans continueing to run after the car shuts off. Since the engine turns the transmission, somehow I don't think the transmission will continue to run after the car has shut off.
 

·
Registered
Joined
·
76 Posts
if its the fans, there is a problem with the control module going bad. i know i have had mine replaced.
[/b]
i had the same problem with the fans staying on before, but it was a quick fix that mazda did to replace the fan control module. you should look on mazdatech to find the service bulletin.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #6
thanks for the help, and yeah i guess it is the fan staying on after i shut off the engine, was i supposed to get a recall letter about this or what???
 
1 - 8 of 8 Posts
About this Discussion
7 Replies
6 Participants
AzMz6
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top