Mazda 6 Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Back again with another problem! I have a 2006 Mazda 6 3.0, got coolant leaking from somewhere but don't know where. I've replaced the water pump "whole assembly", Thermostat and o ring, bypass hose and a set of new spring clamps, coolant T, ECT sensor! Now what I suspect the problem to be is, the water outlet that contains ECT sensor! Any ideas, or anyone had any weird leak story maybe I can relate to my situation?
 

·
Super Moderator
Joined
·
18,109 Posts
The T fittings that feed the TB lines are brittle and known to crack/break. You can either replace them with a T/Y or bypass the TB and use a straight fitting.
He mentioned he replaced the coolant T, but maybe it was garbage and broke again?

OP, do you see where it's coming from at all?
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #4 ·
The T fittings that feed the TB lines are brittle and known to crack/break. You can either replace them with a T/Y or bypass the TB and use a straight fitting.

Thanks for the reply! I dont think its the T because that's a month new! both T's! The puddle of coolant drips under my bypass hose but no leak from that hose!!!! let me show you a pic of what I think is the culprit
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #6 ·
He mentioned he replaced the coolant T, but maybe it was garbage and broke again?

OP, do you see where it's coming from at all?
Thanks for your reply! and Yea yu never know with these T's! But There doesn't appear to be coolant coming from it or around it!
 
1 - 7 of 7 Posts
Top