Mazda 6 Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
88 Posts
Discussion Starter · #1 ·
There is a loud click coming from the front left wheel well on my 07 6i (155000km). It's difficult to reproduce normally with the exception of one condition which is reversing into a parking spot while turning right.

It's reproduceable nearly everytime when I do the following:
Drive forward and start turning left - noromal
Stop and put the car in reverse - normal
Start turning the wheel right - normal
Sart to accelerate in reverse with the wheel turned right - loud click!

It's usually one loud click followed by or two small clicks.

Does anyone have any ideas?
 

·
Registered
Joined
·
88 Posts
Discussion Starter · #3 ·
Thanks for the reply Alexz0524!

I plan on checking everything this weekend and if I'm lucky I'll find a loose nut somewhere. Could be anything but I can't get under my car until late saturday to look into it.
 

·
Registered
Joined
·
88 Posts
Discussion Starter · #5 ·
It isn't likely the steering column or the springs / shocks because. While driving at anything over idle speeds there is no click sound while going over bumps or turning. I checked today to see if there was a rattle while turning left and right at idle speeds and it was rattling. When reversing with the wheels turned to the right is when it's the most noticeable.

It isn't necessarily coming from the wheel, but it's definitely coming from withina foot of it. I'm starting to think it might be the CV joint. I need to check the boots and reversing while turning left to see if I get the same issue.
 

·
Registered
Joined
·
88 Posts
Discussion Starter · #10 ·
Ya I'm way out of warranty now so I'll be doing this one myself. Doesn't look to bad though and the only tool I'll need is a ball joint puller / remover. STill need to pinpoint the issue though.

Went to test the car today and there was no clicking sound while the car was cold first thing in the morning. This afternoon after running errands the click came back by the time I came home.
 

·
Registered
Joined
·
88 Posts
Discussion Starter · #11 ·
Thought I'd update reply to say that I've fixed the issue and it turns out it was my brakes.

Mazda dealer wasn't able to duplicate the issue but still suggested a number of things that could fix what they were unable to diagnose (which I found contradictory; why suggest a fix to a problem that doesn't exist?!). One of those suggestions was to replace my brand new aftermarket pads with mazda pads and replace my original rotors. Went home and took my brakes apart to find that for some reason I installed two shims on outer right brake pad, so I removed the extra shim and the click is gone!
 

·
Registered
Joined
·
2 Posts
Iam looking for a radiator for mazda 6 atenza 2.3 japennesse model my dealership says its not de same 1 as de mazda 6 2.0 pls help I looked everywhere cnt find it
 

·
Registered
Joined
·
1 Posts
There is a loud click coming from the front left wheel well on my 07 6i (155000km). It's difficult to reproduce normally with the exception of one condition which is reversing into a parking spot while turning right.

It's reproduceable nearly everytime when I do the following:
Drive forward and start turning left - noromal
Stop and put the car in reverse - normal
Start turning the wheel right - normal
Sart to accelerate in reverse with the wheel turned right - loud click!

It's usually one loud click followed by or two small clicks.

Does anyone have any ideas?
My 07 Mazda 6, same click/clunk. I found play in the "wishbone" bushing...above the caliper.
 
1 - 13 of 13 Posts
Top