Mazda 6 Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
I have the clear side markers with the bright white led bulbs, the passenger side one is now flickering, well, maybe flickering is not the right word, more like blinking, but really fast. I've had them for almost 9 months with no problems, what would cause this? Wiring? bulb? I've tried "jiggling" stuff but to no avail.
 

·
Registered
Joined
·
1,550 Posts
ill buy them off ya. haha ;) good luck. Try more jiggling! and make sure all of the wires are in securly. Also if its not to much of a hassle, try switching the stock bulb in or the bulb from the other side in and see if it flickers.
 

·
Registered
Joined
·
366 Posts
I had this problem too, but it was in my parking lights, i had the White LEDs in them, i asked my friend what was wrong, he said it could be the ground. But i checked the bulbs, and it was a problem with the bulbs. I ordered new ones and changed it and it was fine. It could be the bulbs, check them before doing anything else. :yesnod:
 

·
Registered
Joined
·
1,479 Posts
i find it that with the LEDs... it's coz' they are either burnt out or gone bad... i have the "strobe light" effect on mine right now! :p
 

·
Registered
Joined
·
51 Posts
Once you make sur eit is not your ground or power it must be the ligh titself, try switching your LED's from left to right and see if the problem moves then you have your answer as to what the issue actually is with the flicker.
 

·
Registered
Joined
·
1,274 Posts
its more than likely that it is your led going bad. try replacing it before you get pulled over for having a strobe light on your car ;)
 

·
Registered
Joined
·
366 Posts
its more than likely that it is your led going bad. try replacing it before you get pulled over for having a strobe light on your car ;)
[/b]
Yea im pretty sure its the LED bulb going bad....cuz mine was like that and it looked like i was strobing down the road... change it before u get pulled...
 
1 - 7 of 7 Posts
Top