Mazda 6 Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I brought my 2003 6 in for the 90K service, and the repair shop put in DEXIII fluid, and now I see these posts that talk about correct versus incorrect fluid. I called the dealer and they indicated that this was the WRONG FLUID. When I left the shop, which was not the dealership, the car was making a noise from the tranny, like wind blowing. Also have the bunt rubber smell.

Can this be due to the wrong fluid?

Thoughts? The shop where they worked in it is telling me that I need to rebuild the tranny. Thanks.
 

·
Registered
Joined
·
181 Posts
yes wrong fluids can ruin your tranny fluid. DEXRON-III is not compatible with the most recently designed transmissions, and the use of these earlier type fluids could result in transmission damage. Mercon V has special additives for automatic 5-spd transmissions. Go back and get the right fluid put in.
 

·
Registered
Joined
·
403 Posts
I brought my 2003 6 in for the 90K service, and the repair shop put in DEXIII fluid, and now I see these posts that talk about correct versus incorrect fluid. I called the dealer and they indicated that this was the WRONG FLUID. When I left the shop, which was not the dealership, the car was making a noise from the tranny, like wind blowing. Also have the bunt rubber smell.

Can this be due to the wrong fluid?

Thoughts? The shop where they worked in it is telling me that I need to rebuild the tranny. Thanks.
Sounds like the idiots just bought you a new transmission.
 

·
Registered
Joined
·
233 Posts
Go to your transmission dipstick on top shoud be the correct type of fluid, or pull it out and etched on the stick is the correct type of fluid. I have an 04 6s and it takes Merc V, it says that on top of the dipstick.
 

·
Registered
Joined
·
4 Posts
My 2003 Mazda6 S takes M-V ATF (Mazda). You must find something that is compatible. I used Mobil 1 multi-vehicle which states on the bottle that it is compatible, but others use Mobil 1 Synthetic ATF which states the same. It solved the problem (along with a bottle of Slick 50) of the slipping and hard shifting from 2nd to 3rd for me. YMMV
 

·
Registered
Joined
·
116 Posts
I got my trans replaced at Cottman Trans, and it was acting up again, so i brought it to Mazda and they said it was ok and as long as the trans fluid was red then it was ok...btw dealerships dont know shit.

well about 4k later i feel like my 1st gear is starting to go...so im gonna drain and fill the trans, and get a UOA to find out if the trans is falling apart from the inside out.

and when i called corprate and told them all this they basicly told me to go fuck myself and the cottman locataion tried to blame my problems on a loose intake hose...

So if the trans blows, Cottman is buying me a new trans, if it doesnt, well then something else is wrong cuz i bought a trans with 300 miles on it and it shouldnt die within 4k
 
1 - 9 of 9 Posts
Top