Mazda 6 Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I have my Mazdaspeed6 this May, but I out of US for three months so it's only around 500
miles in this car. I had check-engine light up yesterday, dealer manager told me it's because
purge solenoid valve fail. They called me this afternoon and told me everything is ok now.
I picked up my car and drove only "5" mins, light up again.......
I just done my recall on Monday, I am not sure if this issue relate to the recall, I just wonder
is anyone who has speed6 has the same problem?
 

·
Registered
Joined
·
788 Posts
I have mine on right now. I had Autozone run their scan tool and it was emissions leak and the second code was excessive emissions leaking...why would that be happening this early on...
 

·
Registered
Joined
·
829 Posts
I have my Mazdaspeed6 this May, but I out of US for three months so it's only around 500
miles in this car. I had check-engine light up yesterday, dealer manager told me it's because
purge solenoid valve fail. They called me this afternoon and told me everything is ok now.
I picked up my car and drove only "5" mins, light up again.......
I just done my recall on Monday, I am not sure if this issue relate to the recall, I just wonder
is anyone who has speed6 has the same problem?
[/b]
Yep, happened to me too. Don't know what they finally did to fix it, but um...yeah, my car was in the shop for like 20 days.
 

·
Registered
Joined
·
2,652 Posts
happened to me.

1st time, reset the battery.

2nd time, reset with scanner.

3rd time, reset with scanner.

1000 miles later and it hasnt return. 3rd times a charm.
 

·
Registered
Joined
·
1,519 Posts
resettin the ecu just ignores an issue...
you need to pull the code and figure out what the cause is..
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
Yep, happened to me too. Don't know what they finally did to fix it, but um...yeah, my car was in the shop for like 20 days.
[/b]
so.....I assume this problem can be solved.....20 days is ok for me, as long as
they can solve the problem, I really worry about anything relate to check-engine
light.....
Does ur dealer tell u the same problem as "purge solenoid valve" after 20 days?
 

·
Registered
Joined
·
940 Posts
happened to me.

1st time, reset the battery.

2nd time, reset with scanner.

3rd time, reset with scanner.

1000 miles later and it hasnt return. 3rd times a charm.
[/b]
Yeah, my oil pressure light kept coming on. Pulled the bulb and no more problem. ;)
 

·
Registered
Joined
·
788 Posts
So when your oil pump fails and you have a sudden drop in oil pressure and your motor seizes what do you do then?
 

·
Registered
Joined
·
940 Posts
So when your oil pump fails and you have a sudden drop in oil pressure and your motor seizes what do you do then?
[/b]
It was a joke.... Teasing with ryceboi and amp about the fact that ryceboi did not mention fixing the problem causing the CEL. Whoosh
 

·
Registered
Joined
·
788 Posts
Aight, so why would my car show excessive emissions leaking? Did that happen to anyone else?
 

·
Registered
Joined
·
11 Posts
Discussion Starter #11
Aight, so why would my car show excessive emissions leaking? Did that happen to anyone else?
[/b]
I am not sure if my case "purge solenoid valve" is same as urs, but I did
hear manager told me this problem casue leaking (gas).....
 

·
Registered
Joined
·
788 Posts
I sure hope this isn't the kind of quality issues I have to look forward to...
 

·
Registered
Joined
·
2,652 Posts
actually, i got the p-0771 code. i figured i just didnt tighten the gas cap enough. its tight now. i got the scanner hooked up all the time too and it will show me if i have a pending code. if it comes up again, ill get it taken care of.
 

·
Registered
Joined
·
829 Posts
so.....I assume this problem can be solved.....20 days is ok for me, as long as
they can solve the problem, I really worry about anything relate to check-engine
light.....
Does ur dealer tell u the same problem as "purge solenoid valve" after 20 days?
[/b]
yeah, it was the purge valve or whatever...they changed the valve the first time, then like changed the whole section around the solenoid the second time and worked. What sucked was the service manager, besides rude, kept saying, "I called Tech Line, but they didn't respond (or didn't know what's wrong) or didn't fax the data back or whatever BS he could think of."
 

·
Registered
Joined
·
489 Posts
I recently got a code P0455: Evaporative Emission Control System Leak Detected (no purge flow or large leak)

So, I checked the gas cap, and it had come loose! The last time I refueled, I had clicked it a couple of times. I reset the code, and tightened the gas cap again, but I'm afraid it might come loose again. It seems very easy to loosen the gas cap; it doesn't take that much force to unseat it. A few good potholes might be enough to jar it loose again.

Does anyone else's gas cap seem very easy to loosen? I don't want to waste time at the dealer having them look at a problem that's "normal".

Thanks.
 

·
Registered
Joined
·
788 Posts
I wonder if that was the problem with mine. The gas cap on my car seems very loose too. I am going to do a battery reset and see if it comes back...
 

·
Registered
Joined
·
788 Posts
I reset the cel taking off the neg. of the battery, we'll see if the light comes back...
 

·
Registered
Joined
·
2,652 Posts
the gas cap is tricky business. i grasp it by the outer rim now and tighten it that way, then pull on it. sometimes the thing clicks even tho its not locked in.
 
1 - 19 of 19 Posts
Top