Mazda 6 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
801 Posts
Discussion Starter · #1 ·
I was turnig left and it was a a sharp turn but I ussally do that once in a while without a problem. I also noticed that the car slides a bit during the sharp turn. After that I noticed the Check engine light turns on. ANy of you guys experienced this berore? The cars runs fine and theres I didn't noticed any engine noise or mechanical problems that might occured during the turn.
 

·
Registered
Joined
·
1,320 Posts
thats usualy a sign that ur engine is gonna blow up. LOl jk no clue bro. U have any mods done to your car?
 

·
Registered
Joined
·
30 Posts
check your oil level. i had this problem 2 weeks ago, except it was a hard right turn that i went through, the pcv valve in my motor had failed and i didnt know it. so my motor was burning off oil. what happened is in that hard turn all the oil was pulled away from the sump causing the system to go dry temporarily and throw a cel. 10 miles later on the way to the shop my motor went...now its in the shop being investigated. thats what it sounds like to me, check your oil level and let me know.
 

·
Registered
Joined
·
801 Posts
Discussion Starter · #6 ·
Ok, I checked the oil level and it was ok. I left the car parked for an hour the same day and when I started the egine, WallllaH!! the check engine light was gone! Probably it was either the wirings from my CP-E intake Maf ci or the misfire of the cylinder...Thanks for the response guys. I thought I have to take my caR to the dealer...Im worried about taking off my modz and re installing it again . :p.
 
1 - 6 of 6 Posts
Top