Mazda 6 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Last night my wife noticed the CEL come on in our 2007 Mazda6 2.3L so once we got home I had a look. I pulled a P0134 - HO2S-11 no activity detected, however I didn't have the car running when I did the code read.
I'm not sure if this DTC only came on because there was no exhaust flow, or if my O2 sensor has failed. Can anybody share some insight on this? In past experience with other makes an O2 sensor failure doesn't throw the MIL/CEL..
I'll have a closer look at the sensor and see what the AFR is reading and check the wiring tonight and if I can't find anything I'll do a KAM reset but would really like to know if that DTC is meant to come on with the car off.
While I'm on the OBDII talk, am I meant to be able to read oil pressure? I couldn't find a PID for it in any of the modules.
 

·
Registered
Joined
·
941 Posts
That DTC has nothing to do with the car running or not. You need to check the wiring going to that sensor before swapping in a new sensor. No activity detected usually means that the PCM can sense the O2 sensor is there, but there is no change in the voltage so there is no activity.

As for oil pressure, no, there is no provision for reading oil pressures. All the PCM cares is that there is a minimum pressure, an actual value is not looked for.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3
I haven't physically check the sensor yet but I did get the code P0131 - HO2S11 circuit out of range low voltage, in addition to the one already mentioned but I will check it out today.

On a lighter note, I ended up finding the PID for the oil min pressure switch.
 

·
Registered
Joined
·
141 Posts
Yeah, it really does sound like there's either a bad connection or the sensor itself is bad. If you can get a multimeter in there, you can pretty easily test it.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #5
Mazda worked out that the post cat sensor voltage was out of spec despite the DTC's FORScan pulled, unless a failed post cat disables the pre cat sensor? I'm not sure. Anyways replaced the rear sensor and she's fine.
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
3 Participants
zoomfactor
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top