Mazda 6 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
626 Posts
Discussion Starter #1
Ok.....Ever since I've purchased this car ive been ive been getting the CEL. I purhcased the car around jan 21, 2003(03 6s). So i took it into the shop and they said it was some type of coil that gotton loose....whatever problem fix...
2 weeks later, CEL comes back on and I take it back to the dealership. Which it takes them 5 hours to fix the problem again. I cant remember what he said the problem was.
Couple weeks later the CEL comes back on and he tells me after holding my car for 4 hours that he has to contact "Regional field Rep" (located in California) because they had to contact them last time for this issue and I had to get a price of shit rental car. So they cleared the CEL and told me that I had to call them back in a week if the CEL comes back on. So pretty much Ive been getting the run around. Car only has 40k miles on it.



So what yall think bout this?
 

·
Registered
Joined
·
1,197 Posts
since you don't have a warranty all you can do is try another dealership, but i would stick with that one because they have the history of the car. when i got the run around by the shop at my mazda dealer, i talked to the head of the dealership....he fired the head of service and this have been great since
 

·
Registered
Joined
·
626 Posts
Discussion Starter #3
I do have a warranty....I got a extended warrant w/ the car when i purchased it
 
1 - 3 of 3 Posts
About this Discussion
2 Replies
2 Participants
canibusfan
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top