Mazda 6 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
204 Posts
Discussion Starter #1
I dunno if anyone else has experienced this but my CEL came on a couple days ago the same time my fuel light came on. Its very weird because as soon as I refueled, the light went away. Never happened to me before. I have this theory that it could be because the engine wasn't getting enough fuel and might be affecting the A/F ratio, (I do have a CPE intake), but if this were the case, why didn't it happen before when my fuel light came on. Well I'm gonna drive it again until i'm low on fuel and see if the CEL comes back on.
 

·
Registered
Joined
·
156 Posts
I dunno if anyone else has experienced this but my CEL came on a couple days ago the same time my fuel light came on. Its very weird because as soon as I refueled, the light went away. Never happened to me before. I have this theory that it could be because the engine wasn't getting enough fuel and might be affecting the A/F ratio, (I do have a CPE intake), but if this were the case, why didn't it happen before when my fuel light came on. Well I'm gonna drive it again until i'm low on fuel and see if the CEL comes back on.
[/b]

How many miles do you have on the car? Could be this perhaps?:
http://forum.mazda6tech.com/about492-0-asc-15.html

or could be as simple as your gas cap was not tight enough before you refueled....
 

·
Registered
Joined
·
99 Posts
correct me if im wrong but the engine only gets one ratio of fuel.... if theres no fuel or theres very little... the engine doesnt get less and it doesnt try to save it. if theres no gas the engine will shut off. but no, i havent experienced this myself... never heard of it personally
 
1 - 3 of 3 Posts
Top