Mazda 6 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Please take time to read.

OK, I'm not good with the mechanics of a car, but I'm halfway convinced this could be engine related. Let me explain my situation.


Blah blah... I had screeching with my car, so I had Pro Care (of BP) change my pro steering and alternator belts. Well, all was fine until maybe, a week later. I'm just getting off of work and I notice my car shuts off when I'm at a traffic light. I figure since I'm in a manual, I stalled out just dazing off in my own world. So I think nothing of it.

Then I notice it does this after another week, specifically when it's extremely hot and my car sat under the sun for 8 hours. Well, a few days ago, it did it again.... except, for the first time, it happened TWICE in one day. It took a while before I could even get the car started again, and at one point, it wouldn't start compeletely and I haven't been able to drive the car since.

Here's a few things I've noticed:


*my car will still squeel when I reverse from parking lots on those "extremely hot" days, but it go's away quickly as I drive
*The car always seems to "shut off" within a mile OR driving 5 minutes, and it happens whenever I'm at a stop light. Coincidentally, the light always changes within a few seconds. I don't know what to think of that one.
*My Uncle said there was nothing in my radiator, or whatever... so we put water in there to cool the engine down. But when I put my car back in my garage, I notice a huge puddle exactly where the water was put, and I occasionally pull my car out and notice a few blots of water, maybe indicating a leak? But for some reason, I feel it has to do with the steering (remember, they changed my power steering belts). I can't really say, but the "water" is sort of a dark orange... maybe light red or brown.
*Last but not least, after I was stranded in my car for a while, I put the emergency break down and the car magically started. I've toyed with leaving it up and for some reason, it won't start at times when it is up.


This all sounds so farfetched and ridiculous. But I just need help ASAP. I have no other means of transportation after tomorrow, and need this solved by the end of the weekend. Any ideas of what this could be, and possible estimate? Because it seems my car is dead.
 

·
Registered
Joined
·
1,196 Posts
not too sure about the other problems but it's normal for some water to be dripping if you've been using your A/C.
 

·
Registered
Joined
·
11,748 Posts
The car always seems to "shut off" within a mile OR driving 5 minutes, and it happens whenever I'm at a stop light. Coincidentally, the light always changes within a few seconds. I don't know what to think of that one.[/b]
You have a bad throttlebody. It needs to be replaced.
http://forum.mazda6tech.com/viewtopic.php?t=4026
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
^ :( I guess I should've noted; while that MAY be the/a problem, I actually have a 626. I assume they don't even do this model anymore, but I can't find ANY other Mazda forums that are active.

I had a good local guy check my car out and he noticed I have a leak in my water pump. He said that's most likely the only problem. A few things here and there can be done, but... it looks like the water pump right now.

I think it is time for a trip to the dealership
[/b]
I would but... I bought my car used. And it's actually a 99. I'm sure they'd kill my pocketbooks just checking it out. But if I'm wrong, please let me know so I can feel better about trusting my car with a mechanic again.
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
4 Participants
adrush
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top