Mazda 6 Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
So I recently bought a 2006 Mazdaspeed6 with 200k on the trans and a rebuilt gen 2 motor 80k miles ago I bought it completely stock but with an accessport, I bought a short ram intake and aftermarket turbo inlet cause the guy had it tuned with a stock air box. Anyways I was only pushing 12 psi with a stage one tune on (should be pushing 17) I replaced some boost lines but there were no obviously bad lines, then I replaced the boost solenoid which didn’t help anything, I then replaced the waste gate actuator which put me up to 13.5 with a stage one tune. Last night I was messing with the tunes and put on a stage one plus tune which is for a Aftermarket cold air intake and turbo inlet the peak psi for that is 16.5 but for some reason I was only hitting 12.75 psi idk why it dropped with a better tune Thought it could be my ecu not sure but the car runs mint doesn’t overboost and it doesn’t underboost it just runs to good to be a simple boost leak anyone else had a problem similar to this?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
Cause I’ve driven in my friends speed3 and mine does not feel like that when you hit boost it’s way under power
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #9 ·
Ok sure I fixed it tho pushing 19 psi again so I’m chilling with no boost gauges for now
 

·
Registered
Joined
·
3 Posts
Would you care to tell what the problem and fix was, am really interested to find out since I'm interested in buying a Speed6 down the line and I'm researching all kinds of pros and cons and situations of other owners!
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #12 ·
Would you care to tell what the problem and fix was, am really interested to find out since I'm interested in buying a Speed6 down the line and I'm researching all kinds of pros and cons and situations of other owners!
It was my fuel internals haha they were shot I replaced them with auto tech internals that I got used for cheap and also put a corksport fuel line in now I’m pushing 20psi the ms6 is a fun ass car and it rips if you just keep up on General maintenance you’ll be chilling I daily mine and for 200k thing handles like a new car
 

·
Registered
Joined
·
85 Posts
I have a black 07 MS6GT bought new with 59K currently on the odometer, I have a similar problem, my boost is around 11 PSI, read from mechanical vac/boost gauge and Dash Hawk, both read close to the same. Boost goes up to 12, then pulls back. I don't know when this reduced boost started because I don't push it in boost often. Installed CorkSport HP fuel pump internals few weeks ago and CorkSport intake last year, boost was normal with the CS intake. Recently installed a TurboSmart blow off valve, and one size up on the tires when the originals were replaced. For appearance I replaced the tail lights with Spyder ALT-YD M603-LED-SM Smoke LED tail lights. With black paint and light tint tail lights, these after market tail lights look like they belong to the car, not add on's.
I had this low boost years ago when I broke the fitting on the stock air box that goes to the waste gate controller. I had an EGR issue and working it, the fitting got broken, not uncommon to happen. I repaired it but inadvertently blocked the fitting hole with JB weld during the repair. Drilled that out after figuring out what I did wrong and boost went back to normal.
Having owned this car for 13 years I still enjoy it. But buying a high mileage version may be a money pit, the person has to be willing to put money into this rare car. Mine is near perfect. I keep a black "A" shirt on the seat back to protect the drivers seat back bolster to protect it.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #15 ·
I would check for a boost leak but 12 psi would be a pretty extreme boost leak you would probably throw a code do you hold boost fine or does it drop more than 1.5psi
 
1 - 15 of 15 Posts
Top