Mazda 6 Forums banner

1 - 20 of 63 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello all,
I've got a 2014 touring and only a few days ago when I park and hit the ignition switch my battery won't turn off. The radio stays on and I can work the cabin lights but the AC turns off. I've tried over and over again depressing the brakes and turning the car on and off and it won't work. I've found if I drove the car about 30 seconds and try again I have success. Is anyone else having a similar issue? I've gone through most of the forum and haven't seen anything similar. Does anyone know a solution? This is driving me nuts. Thanks!
 

·
Registered
Joined
·
916 Posts
disconnect your battery on the negative terminal for 5 minutes and see if the issue goes away. Usually that resets everything and fixes the electrical bugs the car runs into.
 

·
Registered
Joined
·
1 Posts
Hello all,
I've got a 2014 touring and only a few days ago when I park and hit the ignition switch my battery won't turn off. The radio stays on and I can work the cabin lights but the AC turns off. I've tried over and over again depressing the brakes and turning the car on and off and it won't work. I've found if I drove the car about 30 seconds and try again I have success. Is anyone else having a similar issue? I've gone through most of the forum and haven't seen anything similar. Does anyone know a solution? This is driving me nuts. Thanks!
OMG!!!!!!! I thought i was the only one with that issue sometimes takes me up to 7-8 minutes before it will shut down has anyone else has this issue and know the answer? I've taken my car to dealer 3 times and they still cant fix it someone help please
 

·
Registered
Joined
·
326 Posts
OMG!!!!!!! I thought i was the only one with that issue sometimes takes me up to 7-8 minutes before it will shut down has anyone else has this issue and know the answer? I've taken my car to dealer 3 times and they still cant fix it someone help please
This is going to sound really stupid, but... have you tried just opening the driver's door when this happens? Some of the electical accessories (like the windows, for example) continue to work until you open the door.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #8
Still having the issue. Just started again last week, I've been trying to shut my car off for 30 minutes
 

·
Registered
Joined
·
1 Posts
2014 Mazda 6, same issue. After I put the car in Park, hit the ignition button, the engine turns off, but the car goes into Aux Mode.. radio works, and car beeps if the door is open. I put my foot back on the break, move the shifter out of park and back into park, press the ignition button, and it turns off. Its almost like the shifter isn't going all the way into Park. Not sure the proper name for "shifter".

Anyone else?
 

·
Registered
Joined
·
1 Posts
I've been having the same issue for at least around 6 months now with my 2014 6. I've been periodically looking in the forum(s) for answers, and this is the first time I've found anything.

The way I fix it is to pull the shifter all the way to the right (never leaving 'Park') and then letting it pop back to the left. After that, I turn the car back on (no ignition - foot off brake) and then try to turn it off again... hit the "On" button twice, basically. This resolves the issue 100% of the time for me, though it sometimes takes repeating the steps once or twice more. I can also state that this happens every day on almost every drive. Rare to have it NOT happen, honestly.

When I asked about it at the dealer, they seemed perplexed and also had me try some other things I see recommended in this thread while I was there... opening the door, rolling down the driver side window, etc. On that day, we did also have success with the "open door" method, but I haven't tried that since then, given the rate of success with the "shifter" method.

I'm going to try disconnecting the battery to reset things, and see what I get (though I think we did that at the dealership as well).

Will update as soon as I can...
 

·
Registered
Joined
·
1 Posts
Yes, I'm having the same problem with my 2014 Mazda 6. Engine shuts off, but acessories stay on. Going to the dealer this week.
 

·
Registered
Joined
·
5 Posts
I've been wondering about this for some time too. I have a 2014 GT 6 and it's been doing this for about two months now. I have to keep popping it back and forth on park then press the start/stop button multiple times hoping it will eventually work. Has anyone had an update on this yet?
 

·
Registered
Joined
·
3 Posts
Same issue here. Pending repairs to make sure, but as I thought, dealer says the parking switch is bad. When you move to park, switch should register its ok to turn off car but it's not getting proper signal so it thinks it's in gear. Same thing would happen if you try to turn car off in neutral .

Repairs plus labor at dealer about 220 to fix. Checking with my local mechanic to see what that would cost there.
 

·
Premium Member
Joined
·
561 Posts
Same issue here. Pending repairs to make sure, but as I thought, dealer says the parking switch is bad. When you move to park, switch should register its ok to turn off car but it's not getting proper signal so it thinks it's in gear. Same thing would happen if you try to turn car off in neutral.
That diagnosis sounds right on.
 

·
Registered
Joined
·
1 Posts
disconnect your battery on the negative terminal for 5 minutes and see if the issue goes away. Usually that resets everything and fixes the electrical bugs the car runs into.

Has anyone tried this yet? I've been having this issue intermittently with my 2014 Mazda 6, but the frequency has increased in the past week. This would make the 2nd electrical/switch issue my car has had (the first being a faulty solenaid switch, under warranty, luckily). But 2 switch problems in 2 years sounds like lemon law time....
 

·
Registered
Joined
·
2 Posts
Has anyone found a solution to solve this issue once and for all? I think this should be a recall or covered under Mazda. It can definitely drain one's battery for no reason but Mazda's. First Mazda I purchased and this is not a good start to me loving it dearly.
 

·
Registered
Joined
·
2,655 Posts
Yep. There's a switch that tells the car the gear selector is in Park, and it's not working.

Bet if you take the top of the console off (trim panels) you can find the switch, and if it's broken it's probably easy to fix too; it might have come loose from its mounting, but odds are the switch itself is bad.

The stealer is going to charge you bigtime if you're out of warranty on this one but so long as getting to the switch is not hard it should be an easy repair to make on your own, and I would do exactly that.
 

·
Registered
Joined
·
1 Posts
Hello all,
I've got a 2014 touring and only a few days ago when I park and hit the ignition switch my battery won't turn off. The radio stays on and I can work the cabin lights but the AC turns off. I've tried over and over again depressing the brakes and turning the car on and off and it won't work. I've found if I drove the car about 30 seconds and try again I have success. Is anyone else having a similar issue? I've gone through most of the forum and haven't seen anything similar. Does anyone know a solution? This is driving me nuts. Thanks!
I have the same problem, runs the battery down overnight. I have had it to the dealership. HA!! They replaced the battery in the key fob and sent me on my way. That is NOT the problem. It is still doing it.
 
1 - 20 of 63 Posts
About this Discussion
62 Replies
46 Participants
jennwenger
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top