Mazda 6 Forums banner

1 - 20 of 24 Posts

·
Registered
Joined
·
1,078 Posts
Discussion Starter #1 (Edited)
i'm soooo late, but....

mods and pics below!

MODS:
the NEW Airbox mod
http://www.6crew.com/forum/showthread.php?20949-The-NEW-V6-airbox-mod

mustache on grill painted(pebble ash)
fender vents painted and installed
engine cover painted
35watt 6000k HID's
2-12" MA subs
1000watt Kenwood 2ch Amp
TB coolant bypass
wheels+ tail lights plasti dipped
Smoked corner lights
Custom driver side (open)bumper grill
"flying M" painted black
Sylfex aux mod
Clutch switch bypasse 6-11-2011
arm rest 12V socket wired HOT, with ignition off(keeps devices charged)[/COLOR]
Plastic T removed
no more plastic "T" - 6Crew.com Forum
Redline MTL 75w80 MTX fluid

Future Mods:

RX8 18" wheels

MSDS headers w/o cats

leather gutts

CPE intake w/ controller
update: until I beat one!

Maintenance performed:

Coolant flushed+new [email protected] 2008,@115k+160° thermostat,@125(winter) back to the 215° stat

Gear oil [email protected] 2008 75w90(Mazda)
Redline MTL 75w80 @95k 2010 (me), Shaeffers #293 75w90 @130k 2011

PCV replaced once per year.
Speed/sport clutch installed by [email protected]


Power steering [email protected] 87k 2009(me)

Plugs+1 coil due to [email protected] 2010
Brake fluid @100k (me)


reliability issues with MY 6:
cloth seat side supports rippping and collapsing(250LBS could be my fault lol)


axle shaft grease leaking(@100k miles)


rear engine mount broke(@80k miles)


AC line rubbing one of the pulleys(noticed @ 75K miles, fixed with plastic ties before any leaks)


lower AC line not secure, in front of AC compressor next to the 2nd engine bank post cat and it will actually touch the post cat(noticed @ 105kmiles, fixed with zip ties before any leaks)


harness under air box rubbing against the metal below it because its not secured(noticed at 105kmiles, secures with more zip ties and small tubing)


"AA"TB TSB, throttle body replaced at my expense(@80k miles due to CEL)


plastic T broke when doing the TB bypass mod, but they are very fragile and often break anyway when people do plug changes and/or anything in the area that requires T to be moved. (the part is only replaced in a set and is $48 at Mazda, i have a how to for cheaper in my signature below)



following the oil change schedule of every 4-5kmiles will cause low oil level(noticed @100k miles oil loss/burned)from recent notice. i was 2.5qts low when using MotorCraft 5w20 syn blend.


starter noise because of clutch dust on bearings


ceiling started drooping (fixed with heavy duty spray on adhesive)


Driver side door lock actuator spring broke, making it impossible to open the door from both inside and [email protected] 135k miles. (fixed, youtube video of fix uploaded)

Shifter cable broke ~135k miles, possibly caused by loose clutch pedal assembly (the push rod on the pedal can't fully extend because of side to side pedal movement). (fixed the cable, [email protected] mazmart, installed by me in 3hrs)

Clutch slave cylinder replaced, but probably not really needed when I was experiencing hard to shift problems..cause was prob above, part was [email protected] mazmart, @134k miles

@136k miles water pump tensioner failed, I replaced the belt with the stretch to fit water pump belt from the 06+ models.


@138k upper control arms replaced(ball joint stud was leaking grease)...
Also lower front control arms are needed now (bushings are shot).

@134843 replaced broken shifter cable.

@136500 water pump tensioner+ belt broke. Upgraded to stretch fit 06+ 6s belt (tensioner not required)

@138161 clutch pedal assembly replaced. the assembly cracked near corners preventing the pushrod from fully extending. I kept grinding going to 3rd gear. It was harder to start the car with the clutch depressed.

@138162 TOB, cv axles, lower control arms all replaced. pass side cv axle dust boot clamp lost tension causing grease to leak/sling. I also had a growling sound while accelerating esp 1st gear, in neutral, but the sound went away when I pressed the clutch in...The TOB didn't work, I had to replace the trans.

@144360 I replaced the manual trans (mtx). This got rid of the growling sound I was hearing. I think the process of dropping the subframe, then mtx put stress on the pass side motor mount so I had to replace it too.

@145478 driver side wheel hub bearing replaced. my wheel was loose, I could shake it side-to-side.

@145770 passenger side engine mount replaced. I had a rumbling noise while accelerating, esp right turns. I thought my axle shaft aka jack shaft aka half shaft carrier bearings were bad until I noticed the hydraulic fluid leak on the pass side outer tie rod dust boot +a leak on the frame below the mount.

@148k driver side, upper trans mount replaced with AWR 88 duro mount...not for some people (lots of noise and vibration.






04 M6 when i got it in Dec '07




here's now! i like to keep mine simple, but i might get some wheels, in-dash, and power upgrades



dual functioning leds.



Plus I painted the chrome housing for a tinted look.




more photos!!!

11/5/2011 atlanta dyno meet




5/2/2014 hood mod

 

·
Registered
Joined
·
1,078 Posts
Discussion Starter #5
pebble ash fa sho!!!

when i took my bumper off to do my HID's, i took a look at this ugly scrape from a Taco Bell driveway. the driveway was so bad, both front and rear bumpers scraped... no drop for me lol!
 

·
Registered
Joined
·
28 Posts
pebble ash fa sho!!!

when i took my bumper off to do my HID's, i took a look at this ugly scrape from a Taco Bell driveway. the driveway was so bad, both front and rear bumpers scraped... no drop for me lol!
Yea ATL parking lots suck! My previous car was a 3G Eclipse with a 1.5in drop, I went to a meet at The Varsity in midtown and I couldn't even get into the parking lot. I won't be dropping this car.
 

·
Registered
Joined
·
1,078 Posts
Discussion Starter #7
the varsity on north ave? i used to hit it up on the weekend when i had my oldschool...no drop lol
 

·
Registered
Joined
·
28 Posts
the varsity on north ave? i used to hit it up on the weekend when i had my oldschool...no drop lol
Yea the one down the street from GA tech, I only went there like twice, there are just way too many people and traffic is a nightmare! They have monthly meets on one of the Thursdays every month (I don't remember which Thursday it is though) Usually by 6pm the parking lot is packed and you have to park across Spring St.
 

·
Registered
Joined
·
1,078 Posts
Discussion Starter #9
i think it was every 3rd thursday. traffic is a beast down there. ill ask one of my people about which thursdays it is.
 

·
Banned
Joined
·
538 Posts
Good to see your on top of things!
keep up the good work.
Time for rims & headers?
 

·
Registered
Joined
·
1,078 Posts
Discussion Starter #17
thanks, headers before wheels! im still trying to budget in my headers before i buy wheels. i try to take care of the stuff under the hood before i spend on looks lol
 

·
Registered
Joined
·
2,204 Posts
omg im ecstatic that you took off the stick on sidevents...
 
1 - 20 of 24 Posts
Top