Mazda 6 Forums banner

21 - 30 of 30 Posts

·
Registered
Joined
·
10 Posts
Ok, please bear in mind that I am not in anyway very knowledgeable in the technical side of cars. I have throttle body cleaner and my mechanic sprayed it with that like 6 months ago... Does throttle body cleaner help?
 

·
banana boat.
Joined
·
6,987 Posts
TB cleaner will clean the internal of the TB.

Electronics cleaner will clean the electronic connection between the ECU and the TB itself.

Both are recommended.

I believe Justin(thegreatny) is selling a bunch of spare parts and has a TB laying around you maybe able to grab from him cheap. Install is literally 4 10mm bolts+ one screw clamp. It would be wise to just install it yourself.

the only part you could possibly get wrong is righty tighty.... ;)
 

·
Registered
Joined
·
7 Posts
Throttle Body replacement

Sounds like we have the same exact codes... What did you do with you yours?
Originally Posted by kywoodwrkr
I'd vote for the throttle body.
Mine went casters up and just found the sheet with the codes on it last night, but remember the P2135 as the first one.
I got one at a salvage yard($126).
At the end the TB would just click and misbehave.
I'll try and remember to post the whole list tomorrow.
There were five when car went casters up and then three immediately after clearing the first five and trying to restart.
Hopefully the two sets will be helpful to others who have this problem.
Good luck.

 

·
Registered
Joined
·
10 Posts
@Flipper66... I think I might just do that... I'll link up with Justin and see what I can get. But I am gonna need a tutorial from you ;) I'll compensate you.
 

·
banana boat.
Joined
·
6,987 Posts
@Flipper66... I think I might just do that... I'll link up with Justin and see what I can get. But I am gonna need a tutorial from you ;) I'll compensate you.
tutorial on what? it is 4 bolts and 1 clamp.(all 10mm)

undo

replace

reverse

How do I get in touch with Justin?
justin's SN is thegreatny...... PM is the best way to find him.
 

·
Registered
Joined
·
14 Posts
What's strange is I had this same problem yesterday. Here's what I found out though which is really weird. I had actually put in some LED Amber flashers on the tailights. Once I took them out, my car was back to normal. I even reset the computer by disconnecting the battery. Not sure if they were the LED bulbs but ever since then, my car is running fine now. Still puzzled since my outer taillight bulbs ARE LED and my vehicle is not being affected by them.
 

·
Registered
Joined
·
1 Posts
Im thinking this is the same problem I am having. My car died on the highway after accelerating. I restarted it and it was spontaneously revving. The AT light is on, the TCS off light is on, and the squiggly lines is light. I know I have a vacuum leak near my pcv valve. Only mod cold air intake. Assuming what I read was right, all I need is a cx9 TB and a wire harness from Cordova? Would a spacer also help overall?
 

·
Registered
Joined
·
1 Posts
I don't know much about cars, so I thought I'd post here to gain some insight into a problem I've been having lately. I have an '04 Mazda6 with an automatic transmission--its a top of the line model.

My check engine light has been on for months now, and on 4 occasions during the past 3 weeks, without warning, 3 lights turn on: AT, TCS OFF, and the Traction light (the one on the right side of AT), and the car begins to lose power. Upon applying the brakes, it slows down to about 5-7 km/h, and then it begins to jump forward, and never comes to a complete stop unless I shift it into neutral and turn the ignition off. I then restart it, and the problem goes away.

I know I should take it in (going through a divorce so I have limited resources), but I would like some ideas first so I don't go into the shop blind.

Any insight into this problem is appreciated :)
My 2004 Mazda 6 is doing the exact same thing. Did you figure out what is wrong with it?
 
21 - 30 of 30 Posts
Top