Mazda 6 Forums banner

1 - 20 of 25 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter #1
I've been checking this thread for a while trying to figure out what my CEL was on for. I have an I4 (made in Mich, I think) that I bought in November. A few miles after my first oil change (something like 3200 miles) the light came on for the first time. The dealer checked it and couldn't find the problem. After going in twice more (when it came on more) they ended up calling the "Mazda Engineers" and they had no fix at the time.

Just last week I took a vacation and left my car at the dealer. The result when I got back was that there was a software problem with the computer in the car. I think they said something about it was running the emissions checks but thought it wasn't or the other way around or something. Anyways, the dealer said Mazda has now found the problem and it should be fixed in the next "software update" that he assured me would be in sometime over the next 2 weeks.

Am I the only one with this problem?
 

·
Registered
Joined
·
68 Posts
Reading Topic: Another CEL problem

Hi, I'm new to this forum.
I have a 1800 miles, V6 all black/sport package Mazda6.
I brought the car 3 times to the dealership because of CEL.
One of them happened very strangely, I started the car in the morning, the engine RPM went up and down very fast without me pressing on the gaz pedal. I stoped the engine as it freaked me out, then the CEL came on.
Checked this forum, and looked like my vacuum hose was loose.
It was not. Brought it to the dealer, the code was a throttle body error. Which they had already replaced because of previous CEL.
Anyway, last CEL I brought it in, the dealer was talking to Mazda Japan (so they said) and they told me, by next week I should get a new software as the one in my car is buggy. (first year production you know).
I am supposed to call them tomorrow for any news.
Maybe I'll get better mpg with this new software update, who knows.
 

·
Registered
Joined
·
108 Posts
Discussion Starter #4
Reading Topic: Another CEL problem

I might have been. But this is my first car to own, so I'm not so in tune with such things, really.
 

·
Registered
Joined
·
1,262 Posts
Reading Topic: Another CEL problem

Is north america the only place where they're offering the V6? The early release in Japan, etc won't do any of us with the 6s any good as we're on the front lines of this new release. Rats.
 

·
Registered
Joined
·
68 Posts
Reading Topic: Another CEL problem

To answer stretchsje,

Yes, mpg not good at all, and power is interesting.
Feels like in 1st and 2nd gear, a lot of reving and high RPM to achieve low speed/acceleration.
But once in high 2nd, or 3rd shift, at 4k or 5krpms, it shows nice power.
Strange to drive, not very even I'd say.
 

·
Registered
Joined
·
305 Posts
Reading Topic: Another CEL problem

Kyler,

Yep, but Marchhare's problems is with a 4-cylinder.

The common 6s CEL problem -- that exhaust hose under the hood popping off -- is a good example of "new car teething." Had it happen on mine. Mazda already has a replacement kit (hose and sensor, I think) which is now installed on mine; Mazda overnighted it to the dealer.
 

·
Registered
Joined
·
1,262 Posts
Reading Topic: Another CEL problem

Yeah, I was thinking more along the lines with kellis' software ECU problem. I'm keeping a mental note of all these issues for when my 6 arrives. Looks like April is gonna be pretty busy. :sarc
 

·
Registered
Joined
·
42 Posts
Replying to Topic 'Another CEL problem'

just curious...... for those who have experienced a "CEL" problem... was it on a v6 or 4 cylinder engine?? wondering if its just one engine or the other...:sarc
 

·
Registered
Joined
·
791 Posts
Replying to Topic 'Another CEL problem'

Whelp, my CEL went on last night. We'll see what my problem is- car was running better than ever.
 

·
Registered
Joined
·
68 Posts
Reading Topic: Another CEL problem

My dealer updated the software, no change in the car itself as far as I can see.
We'll see in the long run.
 

·
Registered
Joined
·
108 Posts
Discussion Starter #17
Reading Topic: Reading Topic: Another CEL problem

Did they explain the problem, kellis? I'll call my dealer Monday and see if we've got the upgrade here.
 

·
Registered
Joined
·
1,130 Posts
Reading Topic: Reading Topic: Another CEL problem

I have a V6 5 speed and have had CEL lights come on. It did not cause a problem with the performance of the car, it seems to be a software glitch that causes the CEL to light up. Apparently, when I lock the car with the keyless entry, the remote locking of the doors causes a problem in the ECU with the emmissions system, which performs some kinda self test when you shut down the car. They are talking to Mazda to get the software issue sorted out, chalk it up to first year teething issues. I would think the I-4's would have less prob due to the fact they are identical to the Euro/JDM cars that have been out for a while.
 

·
Registered
Joined
·
162 Posts
Reading Topic: Another CEL problem

i have a 6s and my cel popped on before my first oil change....and the said that it happened because of my alarm..or maybe the emissions thing also..they said they dont know how to fix it yet...but also has anyone had problems with like their tansimission slippin?,,,cuz i think mine is...i would appreciate a reply...thank you
 
L

·
Guest
Joined
·
0 Posts
Reading Topic: Reading Topic: Another CEL problem

Drove the new Mazda 6 off the showroom and the CEL popped on 4 hours later! the car has less thatn 60 miles on it...definitely a LEMON
 
1 - 20 of 25 Posts
Top