Mazda 6 Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
635 Posts
Discussion Starter #1
ok after about 3000 kms of driving I got a CEL .. car ran just fine no issues but I had a CEL, so i took it to the dealership ... and he said its because the airbox has been heavily modified :p ...

These were the codes:

P0456 EVAP control system leak detected (very small leak) ON 2 Evaporative ´ (See DTC P0456 [AJ] .)

P1410 VAD control system circuit malfunction OFF 2 Other ´ (See DTC P1410 [AJ] .)

Now I took everything out of the airbox like it said in the guide .... dealer said its not a big deal at all but the CEL might come back again ...

Opinions ??
 

·
Registered
Joined
·
2,652 Posts
this is not related to your airbox. your codes are for the emissions system. take it in to the dealer to get it fixed.
 

·
Registered
Joined
·
4,791 Posts
ok after about 3000 kms of driving I got a CEL .. car ran just fine no issues but I had a CEL, so i took it to the dealership ... and he said its because the airbox has been heavily modified :p ...

These were the codes:

P0456 EVAP control system leak detected (very small leak) ON 2 Evaporative ´ (See DTC P0456 [AJ] .)

P1410 VAD control system circuit malfunction OFF 2 Other ´ (See DTC P1410 [AJ] .)

Now I took everything out of the airbox like it said in the guide .... dealer said its not a big deal at all but the CEL might come back again ...

Opinions ??
[/b]
I can't comment on the P0456, but P1410 is the code that one gets when the green VAD solenoid is disconnected. Reconnect the green connector and the P1410 should go away.
 

·
Registered
Joined
·
4,775 Posts
the p1410 is a pending code, meaning that the code won't throw a CEL on its own, but if another code is thrown, it will go also.
 

·
Registered
Joined
·
4,791 Posts
the p1410 is a pending code, meaning that the code won't throw a CEL on its own, but if another code is thrown, it will go also.
[/b]
Ooh, I forgot that part. Good point.

Also, I just remembered. Isn't P0456 the "you didn't tighten your gas cap" code?

Check your gas cap. If that fails read this thread:
http://forum.mazda6tech.com/viewtopic.php?t=16

Take note of Snap-On's great write up!
 

·
Registered
Joined
·
635 Posts
Discussion Starter #6
Hmmm .... unfortunately i modded the airbox and I cant put the tray back in (i broke some hinges off) .... and I am in Canada, dealers here just ignore all these TSB's ....


"If the owner used the remote to lock the doors while the test was running, the door lock motors caused a drain on the battery and the time for the test never made the specified time. "


This is exactly what happened with me .... no CEL when i turned car off ... came back, remote unlocked doors and BAM !! ....

btw what is the Green VAD you talk about ??
 

·
Registered
Joined
·
4,791 Posts
btw what is the Green VAD you talk about ??
[/b]
http://www.mazda6tech.com/index.php?option...14&Itemid=0

The variable intake duct (VAD) can be considered a second intake duct, prior to the air filter, that opens at higher RPMs. An otherwise restrictive, damped, and quiet intake is employed in the Mazda6 airbox. Beyond 4500rpm, the second air duct opens on the side of the airbox, allowing a shorter, louder, and larger path of air into the engine. With the VAD, the intake of the Mazda6 is never starved for an air source, yet it can stay quiet at lower RPMs. On the Mazda6, the air from the 2nd air duct is also a cooler air source- all the way to the driver's side of the engine bay.[/b]
A solenoid controls the opening and closing of the VAD. It has a green female plug. It's usually wired to the car with a green male end.



You're getting a P1410 because the car is thinking:

"Hey! Something is wrong! It seems I'm not connected to the VAD anymore! Check that connection!"
 

·
Registered
Joined
·
635 Posts
Discussion Starter #8
I am sure I plugged it back in ... hmmm ... i'll double check ....

btw my dealer charged me $100 for "diagnostic check" for the CEL ... is that right ?
 

·
Registered
Joined
·
1,550 Posts
hahahah you got scammed. jk. but i thought it should of went under the warranty, especially for a scan. ( i am no pro though, but i know my moms oldsmobile premier (yes shes a soccer mom) <33 threw a CEL once because its gay. They didnt charge.
 

·
Registered
Joined
·
635 Posts
Discussion Starter #10
yeah man I dont get it ... They replaced starter motor, windshield washer tank/sensor all under warranty and then charge me for this !
 

·
Registered
Joined
·
1,320 Posts
they charged u cuz they thought the cels were caused by ur modifications which arent covered under warranty
 

·
Registered
Joined
·
635 Posts
Discussion Starter #12
they charged u cuz they thought the cels were caused by ur modifications which arent covered under warranty
[/b]
Bingo thats what Mazda Canada said too, I would be charged a diagnosis fees if the cause isnt covered under MAP ... stupid gas cap caused a CEL, and there was the pending VAD CEL because of my airbox mod and I got nailed for that ... oh well atleast I dont need a new engine .. lol ..
 

·
Registered
Joined
·
635 Posts
Discussion Starter #13
the CEL came back again ... and I am sure its the same code ... it didnt come on while running but on start-up ... oh well i guess i'll just clear it by disconnecting battery ..
 
1 - 13 of 13 Posts
Top