Mazda 6 Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
444 Posts
Discussion Starter · #1 ·
I got that Ecu reflash and I have to say that I feel like I have lost the sports car I had grown to love. The boost is all screwy and at times the turbo spudders when the pedal is floored. Example: I kicked it in 3rd gear at about 45mph, and when I got to about 55-60mph the turbo stopped making boost for like a split second. I thought that maybe it would only last for a few days, but it has been going on for over a week now. My car is no longer quick and responsive like it used to be. You guys know how it is when you're in seconds gear and you kick it a little right......it used to be instant power. Now my car seems to lag at first and then go. It has lost a lot of that low end torque which was so fun to feel.

Not really searching for answers I just wanted to vent a little. I have read some of the other complaints about this reflash, but that was the night after it was done. I imagine the dealership will not flash my car back to its original state, but hopefully they can do something for me. It just does not feel like the same car.

Yes I run 93 and no I have not done anything else to the car. I dunno.....what do you guys think about that? I mean should the turbo really spudder for a sec while its making boost after about 3 seconds? Is this something I should be very concerned about and take it back for, or are the people just going to say I am wrong and thats what its meant to do? :swearin:

Warmest Regards
 

·
Registered
Joined
·
176 Posts
I got that Ecu reflash and I have to say that I feel like I have lost the sports car I had grown to love. The boost is all screwy and at times the turbo spudders when the pedal is floored. Example: I kicked it in 3rd gear at about 45mph, and when I got to about 55-60mph the turbo stopped making boost for like a split second. I thought that maybe it would only last for a few days, but it has been going on for over a week now. My car is no longer quick and responsive like it used to be. You guys know how it is when you're in seconds gear and you kick it a little right......it used to be instant power. Now my car seems to lag at first and then go. It has lost a lot of that low end torque which was so fun to feel.

Not really searching for answers I just wanted to vent a little. I have read some of the other complaints about this reflash, but that was the night after it was done. I imagine the dealership will not flash my car back to its original state, but hopefully they can do something for me. It just does not feel like the same car.

Yes I run 93 and no I have not done anything else to the car. I dunno.....what do you guys think about that? I mean should the turbo really spudder for a sec while its making boost after about 3 seconds? Is this something I should be very concerned about and take it back for, or are the people just going to say I am wrong and thats what its meant to do? :swearin:

Warmest Regards
[/b]
Some people have not been happy with the reflash, but your problem sounds unique. If you mean that the boost begins at higher rpm, then that is common to all. However, when my boost begins, it doesn't have interruptions until it begins to fade somewhere over 5500 rpm. I'd have the dealer look at it. Good luck.
 

·
Registered
Joined
·
1,308 Posts
^^^ LoL... Ignore that retarded shit....

That being said... "IF" you can reproduce this... Take it into a dealership.. tell them about the problem.. AND!!!! Most important tell THEM you want to SHOW them the problem... take a tech out with you... show them what happens.. then pull over.. let them drive.. and show them how to make it happen again....

You're lucky if you can do that... the only "issue" with my speed6 I can reproduce is the 3rd gear hickup... which only happens under WOT racing type situations... and i'm starting to learn how to prevent it.... (basically have to keep the throttle up... put more wear on the clutch... power shift in a way)....

So yeah... prove to the dealership that the car does not run correctly... and smoothly... The answer "were sorry... thats the car you bought" is not correct and not something they are allowed to use. Similar to the RX-8 situation years ago... if there really is a problem... they are required by law to either A) Fix it... B) Continue to attempt to fix it and C) Refund or replace the vehicle if A and B fail...
 

·
Registered
Joined
·
49 Posts
^^^ LoL... Ignore that retarded shit....

That being said... "IF" you can reproduce this... Take it into a dealership.. tell them about the problem.. AND!!!! Most important tell THEM you want to SHOW them the problem... take a tech out with you... show them what happens.. then pull over.. let them drive.. and show them how to make it happen again....

You're lucky if you can do that... the only "issue" with my speed6 I can reproduce is the 3rd gear hickup... which only happens under WOT racing type situations... and i'm starting to learn how to prevent it.... (basically have to keep the throttle up... put more wear on the clutch... power shift in a way)....

So yeah... prove to the dealership that the car does not run correctly... and smoothly... The answer "were sorry... thats the car you bought" is not correct and not something they are allowed to use. Similar to the RX-8 situation years ago... if there really is a problem... they are required by law to either A) Fix it... B) Continue to attempt to fix it and C) Refund or replace the vehicle if A and B fail...
[/b]
Yeah there is another thread here on the stutter you mention, but I have the same problem as Perfect Xtreme with a hesitation in Third under WOT going through the gears. Has seemed a little better with the cold weather we have been having in Texas. There is definitely some goofy stuff going on in engine management on this car and yes, some of the fun factor is gone after the reflash. Most notable at highway speed and lower RPMs...the pull is gone from when I drove it home from the dealer :tear:
 
G

·
I have almost the exact same troubles you are having. I have taken it to the dealership once and they could not reproduce the problem. My tech requested that I take him out and reproduce the issue for him.

I am also having and nasty grinding noise when I shift to from fourth to fifth gear and high rpms. This is usually followed by a puff of dirty air out the back. It is not black, but a brownish smoke.
 

·
Registered
Joined
·
127 Posts
Not really searching for answers [/b]
sadly, you likely won't get any here anyway. based upon previous posts with complaints similar to yours, before all is said and done you will be labeled a troll and this thread will get deleted.....
 

·
Registered
Joined
·
286 Posts
sadly, you likely won't get any here anyway. based upon previous posts with complaints similar to yours, before all is said and done you will be labeled a troll and this thread will get deleted.....
[/b]
It sounds like you are trying to provoke something.
 

·
Registered
Joined
·
51 Posts
I talked to the service department at my local Mazda and they said I didn't have to get the reflash if I didn't want to. Also, it would not affect my warranty but they said might affect my drivability. So I'm staying away from the reflash for as long as I can. :drive:
 

·
Registered
Joined
·
4,524 Posts
Okay you guys are just shooting yourselves in the foot.....

What happens when you get that race against that STi and you are close to beating it by a car length, then all of a sudden your boost pre maturely cuts off, your car runs sluggish...and he dusts you. You are going to regret not getting the reflash....
 
1 - 11 of 11 Posts
Top