Mazda 6 Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
So I have a 03 6s mt and i Replaced the throttle body with a new otb from cordova. and i noticed quiet the throttle lag and it felt like my motor mounts were going bad. so i replaced them with awr mounts and things got a little better. Now my issues are throttle lag and when i put the clutch in to start slowing down my engine almost dies and the automatic choke kicks in (or whatever kicks in) and revs back up to 1500-2000rpms then drops back to 700 idle. So I'm debating on getting the software upgrade for the new throttle body for 95 bucks if its going to even do anything?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
I had to remove the battery completely to swap out the trany mount and i"m pretty sure the vac hoses are good I'll double check in the morning.
 

·
Registered
Joined
·
5,758 Posts
Reseting the ecu i s gonna cause the casue to idle funny and stall from time to time for the next day or two after reset.

So I wouldn't worry. And plus there is a ecu reprogram for the the car that pertains to the throttle body. Give the car a chance to learn then if u still have issue post up
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
I have been driving it for 2 weeks and still about the same one of the strangest things is when i put the clutch into shift and my rpms are about at 4k the car revs up 500 or so rpms more. I did have the cel P2135 I swapped out the tb.
 
1 - 5 of 5 Posts
Top