Mazda 6 Forums banner
1 - 18 of 18 Posts

·
Registered
Joined
·
1,461 Posts
Discussion Starter · #1 ·
I've seen this discussed on several other threads.

Just thought I'd post another 1st hand experience.

After installing the DP, and wiring in the diode, I'm glad to say I haven't seen a CEL in close to 600 miles.

I'm typing with crossed fingers.....and hopefully it will remain off, but i've got no CEL!!!!

Forrest
 

·
Registered
Joined
·
2,371 Posts
CP-E catless DP + slightly drilled O2 hole + soddered in screen + 4,500 miles = No CEL

Just FYI.

It's bound to burn outa there eventually, but I'll just sodder a new one in.

No cutting sensor wires (for those fearfull of the dealership).
 

·
Registered
Joined
·
1,461 Posts
Discussion Starter · #3 ·
CP-E catless DP + slightly drilled O2 hole + soddered in screen + 4,500 miles = No CEL

Just FYI.

It's bound to burn outa there eventually, but I'll just sodder a new one in.

No cutting sensor wires (for those fearfull of the dealership).
[/b]
Is that the 'leaky faucet' mod I've heard about?

Didn't understand what that was about, but if it works, it's all good!!
 

·
Registered
Joined
·
2,371 Posts
LOL, that's the one. Drill out the hole a little, and sodder in the faucet screen. It vaugely simulates a cat for just the 2nd O2 sensor. It worked on my Evo for a long time as well, but eventually it burned through and I had to do it again. I would like to use platinum mesh (like a real cat) so it won't burn up, but I don't feel like destroying my cat to get it.

If anyone has a spare cat sitting around from a past vehicle or something, you could tear it apart and sell small 3/4" circles out of the numberous screens for $5 or so and make a little extra scratch. I would test how many would be neccessary per order.
 

·
Registered
Joined
·
1,396 Posts
I've seen this discussed on several other threads.

Just thought I'd post another 1st hand experience.

After installing the DP, and wiring in the diode, I'm glad to say I haven't seen a CEL in close to 600 miles.

I'm typing with crossed fingers.....and hopefully it will remain off, but i've got no CEL!!!!

Forrest
[/b]

I still haven't bothered to fix my CEL from the downpipe. I guess I'll cut off the extension and try the diode trick--my OBD2 inspection is next month, so hopefully it works for me.
 

·
Registered
Joined
·
1,461 Posts
Discussion Starter · #7 ·
LOL, that's the one. Drill out the hole a little, and sodder in the faucet screen. It vaugely simulates a cat for just the 2nd O2 sensor. It worked on my Evo for a long time as well, but eventually it burned through and I had to do it again. I would like to use platinum mesh (like a real cat) so it won't burn up, but I don't feel like destroying my cat to get it.

If anyone has a spare cat sitting around from a past vehicle or something, you could tear it apart and sell small 3/4" circles out of the numberous screens for $5 or so and make a little extra scratch. I would test how many would be neccessary per order.
[/b]
Does that mean that there is an exhaust leak in the pipe near the 2nd cat, or is the material such that it's a tight enough to seal?

I'm a bit confused? Do you just put the hole anywere, or near the sensor?
 

·
Registered
Joined
·
2,371 Posts
In CP-E's DP, there is an extended 2nd O2 bung with a small hole to allow a restricted amount of exhaust gas to reach the sensor. This was their attempt to fix the CEL, which eventually fails (80-160 miles). The hole is too small and you get a MIL for the 2nd O2 sensor not seeing enough exhaust gas to take it's readings. You have to drill that hole out a little more, then sodder the screen(s) over that. Then, plug the O2 sensor back in and go. No more CEL or MIL, and no cutting/splicing wires.

If CP-E ever gets around to toying around with this, it will come standard on their catless DP. They are little busy at the moment though trying to keep the evil customers happy. :D
 

·
Registered
Joined
·
3,545 Posts
Just got a CEL on the DP, no diode. After about 80 miles.
 

·
Registered
Joined
·
1,461 Posts
Discussion Starter · #12 ·
I thought I've read people getting them at 375 miles. So I'm still worried.
 

·
Registered
Joined
·
1,396 Posts
Cut off the extension on the CP-E downpipe yesterday, and soldered in the diode today. No CEL or pending codes after about 35 miles! Before the diode install I always had a pending code by about 5 miles, and the light was on by 15 miles. Hopefully this fixes things for good...
 

·
Registered
Joined
·
1,461 Posts
Discussion Starter · #16 ·
Cut off the extension on the CP-E downpipe yesterday, and soldered in the diode today. No CEL or pending codes after about 35 miles! Before the diode install I always had a pending code by about 5 miles, and the light was on by 15 miles. Hopefully this fixes things for good...[/b]
I'm at a little bit over 700 miles now I believe?
 

·
Registered
Joined
·
1,396 Posts
Checked the IM monitors last night at about 55 miles since the diode install--the O2 sensors passed both the ECM self tests, so I should have no problems passing my OBD2 test next week. CPE should just use a reagular rear bung and include a diode with the DP.....
 

·
Registered
Joined
·
2,371 Posts
Or they could leave it with the extention, and weld/sodder in a couple disks of platinum mesh to simulate a cat for only the 2nd O2 sensor. Then their unit wouldn't require cutting any stock wires, so you wouldn't get a weird question if you have to take it in. I'm sure it would be a little more expensive for them, but I think it would pay off in the long run.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top