Mazda 6 Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2009 Mazda6 with the 3.7L V6 that I got in June 2009. Starting about a 6-7 weeks ago, when accelerating casually, it shifts normally at 40 mph (I believe it is shifting into 4th gear) and about a second later the rpm drops from 2000 to around 1500 (which it didn't used to do) and then there is a rattle in the engine. Is anyone else experiencing this or know what might be the cause of this?
 

·
Registered
Joined
·
1,073 Posts
Interesting.

The 1st gen is in 5th by 40 and goes into 6th at around 42. In 6th the rpms will fluctuate a bit around that area. I always attributed it to the torque converter going in and out of lock-up. Never really thought about it much.

But the rattle I can't explain.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
QUOTE (Spazdog @ Jan 17 2010, 06:49 PM) index.php?act=findpost&pid=1630432
Interesting.

The 1st gen is in 5th by 40 and goes into 6th at around 42. In 6th the rpms will fluctuate a bit around that area. I always attributed it to the torque converter going in and out of lock-up. Never really thought about it much.

But the rattle I can't explain.[/b]

You are right. I have been paying attention to the shifts and it is shifting into 5th at 40 and almost immediately shifts into 6th gear. The rattle I believe is the valves I'm hearing when the engine is under load at such a low rpm. I'm going to be passing this info along to the dealer. I know this wasn't happening until several weeks ago. Thanks for your reply on this.
 
1 - 3 of 3 Posts
Top