Mazda 6 Forums banner

101 - 118 of 118 Posts

·
Registered
Joined
·
491 Posts
Discussion Starter #105 (Edited)
It's been a while since I last posted here. These days I've been sticking to Instagram (link in my sig) to post updates and such.

As of late I haven't done too much to the car. A little maintenance here and there. I recently removed the door guards and badges. I was trying to remove the rear emblem but I think it's snapped in. If that's the case I could have used body filler to plug the hole and paint over it...Eh, another time. Lol.

While cleaning the residue off the "V6" emblem I had a lapse of judgment and went straight to the sand paper (2000grit) instead of getting the soap and water first. (@[email protected]). As you can image I have a nice little blemish (albeit not to little to me) right where the "V6" emblem is. Folks...Don't be like me. PurplePower and elbow grease does the trick..

My V2 throttle body came in yesterday. I'll be putting that on this week :D

https://youtu.be/bZwarZmcoXY
 

Attachments

·
Registered
Joined
·
491 Posts
Discussion Starter #106
Update since my last post:

* Replaced the rear pads (Carbotech 1521) and rotors (StopTech slotted)
* Installed BC coilovers
* Installed front lip (STI)

My Steeda front end links got damaged during the coilover install, so I'll be going with the AWRs instead.

In other news, I finally set aside some money for the internals on the turbo build. No estimation of when it'll be completed, but things are moving in the right direction.

//WILL POST PICTURES LATER//
 

·
Registered
Joined
·
491 Posts
Discussion Starter #111
Just got word from my pops that he's in the process of ordering parts for the engine build. This has been a long time in the making. Will keep you updated on any developments.
 

·
Registered
Joined
·
491 Posts
Discussion Starter #114
One of the remaining issues I'm still having with my 6 is the idle dropping/becoming erratic when the clutch is pressed in. From what I've been reading this was caused by running the 3.7 OTB and being the unlucky one to have the harness issue. (Go figure...) This was also accompanied by a few CELs:

P2135: Throttle Position Sensor No.1 / No. 2 Voltage Correlation
P0123: Throttle Position Sensor No.1 Circuit High Input
P0222: Throttle Position Sensor No.2 Circuit Low Input

I put in the diode (Part # Ajt1-13-Zs8) and so far the CEL has not come back, but I am still having issues with the RPMs dropping (sometimes stalling) when the clutch is pressed.
 

·
Registered
Joined
·
491 Posts
Discussion Starter #115
Well folks I have a crap ton of new parts coming in:
Headlights
Corbeau CR1 seats
Harness Bar,
4pt harness.

In addition to the new shiny bits, maintenance is coming along as expected. The exhaust leak is fixed. I'll be replacing the flex pipe and swapping the cat for a straight pipe and adding a resonator. Pics to come in the upcoming weeks as I get everything installed.
 

·
Registered
Joined
·
491 Posts
Discussion Starter #116 (Edited)
Strut Bar Sanded and Polished.

I finally finished sanding and polishing the strut bar. Now some may say that I should just bought a new one and saved myself the money, time and hassle. They would be right; but there's something about doing work with you own hands that I always find more satisfying. So here is the end result.

 

·
Registered
Joined
·
491 Posts
Discussion Starter #117 (Edited)
// 4/9/2017 //
Quite a few things happened this weekend. As you all know I finished polishing my strut bar and she's finally in.



I also installed my Corbeau CR1 racing seats. This was by no means an easy install. Straightforward? Yes, but not without a little tooling around in typical DIY fashion. Right off the bat the holes for the seat bracket did not align. The driver side was somewhat decent and requires some burring of the steel to make clearance. The passanger side was very off and needed a new hole in the frame to be added. (on my follow up list).

I still have not decided what I am going to do about the airbag light. That's something to be addressed at another point.





That's the good…..now here's the bad….

 

·
Registered
Joined
·
491 Posts
Discussion Starter #118
End of a Chapter...And A Lesson to All

Well folks it's been a while since I wrote on here. The good news is that after I blew the gasket I was able to get the engine replaced with a spare. About 3 weeks later the clutch (FX200) went on me. I decided after that to udgrade to a FX300 and change the flywheel (SPEC). Shorltly thereafter while doing some work to the car I (unbeknownst to me at the time) pinch the throttle body harness where the intake meets the head. This led to a plethora of troubleshooting, swapping parts and eventually buying a new ECU. Having had enough I decided it was best to cut my losses and start anew. I recently picked up a red speed6 in CT and am in the process of tearing down the V6.

While this is definitely a step in the right direction I was and still am a heavy supporter and fighter for the V6. Truth be told I was pretty upset that I overlooked this, despite being happy with the new car and looking forward to modding it. Let my struggle be a lesson to my fellow wrenchers. Slow Down. Look. Look Again. Look Some More. Keep On Looking. TRACE WIRES. Lol. It may sound silly, over the top, OCD, but sometimes it's the little things we miss. I consider myself a very capable backyard mechanic. However, this was thing that I couldnt make heads or tales of.

Having said that this is the end of my V6 build. The Phoenix lives on, reincarnated in my new speed6. I'll be starting a thread on that build here in a few days time.
 
101 - 118 of 118 Posts
About this Discussion
117 Replies
17 Participants
23TDuratecMerkur
Mazda 6 Forums
Mazda6club.com is a forum dedicated to the Mazda6 / Atenza. Come and discuss reliability, performance, modifications, and more!
Full Forum Listing
Top