Mazda 6 Forums banner
41 - 49 of 49 Posts

·
Registered
Joined
·
9 Posts
I don't believe that is a normal function anymore ..after my transmission failed and I had another installed the replacement one didn't do this .. Ive got 30k on this new transmission and it has never done this bucking and jerking when creeping. First transmission made it to 83k before it failed.
 

·
Registered
Joined
·
1 Posts
Hi everyone,

I bought a CPO 2018 Mazda6 with 5k on it on Jan. Currently at 10k and Im experiencing the exact same issue quiet often. Same thing with the dealership, they cannot replicate and their software check looks good so they won't do anything. Just wondering if anyone had any luck.

This is very annoying and painful. Wish Mazda does something about this.
 

·
Registered
Joined
·
102 Posts
Unfortunately nothing came of my last visit where the tech acknowledged what I provided in my video and sent it in to Mazda Canada along with some computer logs they pulled. Possible that by the time I got in there there was no longer any evidence in the computer.

I haven't had it happen since. But my car's also been parked since April and I only really ever noticed it in mild temps. Car should be back on the road soon and I do intend to follow up with Mazda if it resurfaces. My assumption is I will see it again in the fall as temps cool a bit if I don't see it over the summer.
 

·
Registered
Joined
·
8 Posts
I still have the same issues after 30,000 miles. Brought in 3 times but tech couldn't replicate the problems however I just noticed that the jerking is gone whenever fresh oil is in since I brought it in whenever I have to change the oil. And after driving for over about a 1000 miles later the problems would come back. I guess that was why the tech couldn't replicate my problem when I brought it in. I would tell them during my next oil change. Also this TSB that may be applicable to the issues as well https://static.nhtsa.gov/odi/tsbs/2020/MC-10176968-0001.pdf
 

·
Registered
Joined
·
2 Posts
It is 2022, and i have Mazda 6 2021 2.0 with skyactiv G engine. I would like to update you, this issue still there i notice it when the car 5K. I take the car to the dealer, they know the issue very well. Before we do the test drive he updated me with issue. This issue happens while driving in low speed. Above 10km/h to 35km/h and RPM between 1000 and 1200. They told me it is in all mazda cars with Skyactiv G engine. The problem not only in 6 models.. It is in 3 and CX3 and CX30. This issue makes me to hate the car, and will never buy Mazda again.
 

·
Registered
Joined
·
7,471 Posts

·
Registered
Joined
·
206 Posts
There is an easy fix for this as my 2016 Mazda 6 Sport had this problem as well as many other 3rd gen 6 owners with an automatic transmission. The OEM rear torque strut mount has a ton of play in it and is not firm enough. The best fix without increasing NVH much if any at all is the AWR rear torque strut mount with the 62 durometer bushings. CorkSport has their version which I tried first as I was not aware of AWR's existence, but it was too large of an increase in NVH where I swapped it after 3 months. I have a post detailing the comparison and many others have been satisfied with the AWR mount. Gives you a whole new feel of being one with the car.
 

·
Registered
Joined
·
7,471 Posts
The OEM rear torque strut mount has a ton of play in it and is not firm enough.
Not only that, the design allows it to wear out faster than normal. I know mine was toast by 30k.
 
41 - 49 of 49 Posts
Top