Mazda 6 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I removed my battery a few days ago to put in another car that I picked up recently to load onto a trailer, the 2017 Mazda 6 was without the battery for maybe 6-7 hours and when I got back, I replaced the battery and noted the two warning lights. There arent any CEL on, nor does the vehicle drive funny. I have tried turning the wheel to the right and then to the left all the way, holding the TCS button for 10+ seconds....but nothing seems to make it go away...does anyone have any ideas? I'm not sure whats going on, they werent on prior to this.

Also I cant remeber my login to my old account.. not really a new member.
 

·
Registered
Joined
·
703 Posts
Welcome back!

I have nothing to contribute except to try a new, fresh battery although I find it nonsensical if you are sure that you have a full charged battery and the car is running fine.
 

·
Registered
Joined
·
78 Posts
Do you have a GT with ELOOP? Try unplugging the connector near the battery to attempt to reset the ELOOP system.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I had it fixed, I'll post the fix in case anyone runs into this issue again in the future. It's one of the dumbest ways to reset a light I've ever seen...
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5 (Edited)
238110
Now that I posted it, Its super hard to read.. so let me do the steps.

1.Confirm CMU is connected.
2. Confirm the ROOM fuse is installed properly
3. Change the Temp and Distance in MAzda Connect system settings
3a. Temp Farenheight to Celcius (or vice versa)
3b. Distance Miles to kilos or vice versa
4. Turn ignition OFF
5. Remove Room Fuse.
6. Press and hold the tripmeter reset buttong more than 5 seconds.
7. Install the ROOM fuse
8. Turn the ignition ON.
9. Delete the DTC(s) using M-MDS
10. Return the original unit of measurement for temp and distance.

Note: if DTC codes do not clear refere to workshop manual DTC U0323 Skyactiv -G
 
1 - 6 of 6 Posts
Top