Mazda 6 Forums banner
81 - 100 of 104 Posts

·
Registered
Joined
·
108 Posts
same noises here...2014 grand touring....love the car EXCEPT the noisy suspension....bought the car with 55k on the odometer, at 58k now....anyone know if Mazda will honor the TSB since i am way outside of warranty at this point?
 

·
Registered
Joined
·
76 Posts
I just bought my car. I like everything about it except that hair raising creaking! Got a used 2014 m6 I-sport. It wasn't as noticeable until recently. Maybe because I anticipate it now? Anyway I'm going to the dealer Monday and hope they fix it wotjkit me paying a service fee. I did see someone say that they just replaced their control arm. Might do that if Mazda doesn't want to help.

Sent from my SM-N920V using Tapatalk
 

·
Registered
Joined
·
3,658 Posts
Probably not the control arm; there's a rubber bushing in there (rear mount) and I had a bit of creak on first couple of bumps in a given day. Started hitting it with silicone spray when under there to rotate the tires, which would work for a while then it would come back..... around ~60k miles or so it disappeared and has stayed gone.
 

·
Registered
Joined
·
76 Posts
Probably not the control arm; there's a rubber bushing in there (rear mount) and I had a bit of creak on first couple of bumps in a given day. Started hitting it with silicone spray when under there to rotate the tires, which would work for a while then it would come back..... around ~60k miles or so it disappeared and has stayed gone.
i guess I'll have to see. I took it up to the shop and the guy said he was positive it was the lower control arm. What spray did you use just in case?

Sent from my SM-N920V using Tapatalk
 

·
Registered
Joined
·
76 Posts
Just an update. I had both of my lower control arms replaced yesterday, and i hear absolutely nothing from the front now!! No more of that buckling sound when I turn my wheel. Let's hope it last.

Sent from my SM-N920V using Tapatalk
 

·
Registered
Joined
·
191 Posts
I’m having the same problem here sapphir8. Only happens on down ramps in my garage when I hit the end flat point or bumpy roads, not when I turn the steering wheel full-in. You called it a creak, but mine sounds just like yours on your video: more like a suspension groaning noise. Took it to the dealer and they replaced the struts as well as some bushings but noise is still there. Has your issue been fixed? And yeah it’s not lost on me that this is a-year-old post. I’m hoping tho some resolution for you was found that I can take to my dealer- since they can’t find the solution.

I personally get a creaking noise when I go down a sharp incline at my parking garage, or sometimes just braking. They've replaced a few things, but it doesn't change. It's on the driver side and attached is a youtube link to hear it. They can't duplicate it, but I can within 15 minutes of getting it back.


It happens at the 5 second mark. This is the only thing that really bothers me about my car. 2016 Mazda6 Sport
 

·
Registered
Joined
·
3,658 Posts
Spray some silicone around the bushing at the back end where it attaches to the subframe (where the control arm goes through the bushing)

That stopped it on my car; it came back a few times, but eventually stopped entirely.
 

·
Registered
Joined
·
379 Posts
I’m having the same problem here sapphir8. Only happens on down ramps in my garage when I hit the end flat point or bumpy roads, not when I turn the steering wheel full-in. You called it a creak, but mine sounds just like yours on your video: more like a suspension groaning noise. Took it to the dealer and they replaced the struts as well as some bushings but noise is still there. Has your issue been fixed? And yeah it’s not lost on me that this is a-year-old post. I’m hoping tho some resolution for you was found that I can take to my dealer- since they can’t find the solution.

I think I have a similar noise in my 2018 Mazda 6. Dealer is trying to fix it with no luck. I started a new thread a few weeks ago on it, you may want to check it out.
 

·
Registered
Joined
·
2 Posts
I'm probably bumping a really old thread here, but its what google showed me in top searches.

I've got the same issue on my mazda6 sport nav 2016, only happens when its cold, once engine is warm or been ran about for a few miles it goes.

I've even took it back to the garage I bought it from, 4 times now, each time they couldn't find anything. I think I'm starting to lose the plot? Am not going mad am I? I've recorded the noise. Video here:

Does anyone have a fix for this noise yet? Its the only let down of the car so far, apart from that its awesome to drive.

Thank you.
 

·
Registered
Joined
·
1 Posts
Old thread but leased 2020 mazda3 in March and 3k miles in I started hearing a small click every time I press the break pedal going in reverse. Took it to a mazda dealer, they found nothing but told me, they tightened all the bolts. One month in and the click sound turns in to a metal knock so loud that bystanders notice. Took it to the dealer, showed them a video but they didn't seem to care, the receipt said "they tightened the bolts on the chassis torque. I drive the car home and I hear the clicking sound, no more metal knock. Took it back to mazda and told them I feel unsafe driving it, fixed it or give me a lemon application. They began acting like they care and took me to the manager. Drove a loaner for 5 days. They called me back saying the car is ready. A specialist came from Mazda USA and told them it's normal and showed them how to reduce the sound. Starting to regret buying it. Chose it over new Nissan Sentra.
 
81 - 100 of 104 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top